Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FSP 0.25 quircks #51

Closed
OutcastZeroOne opened this issue Aug 3, 2014 · 10 comments

Comments

Projects
None yet
4 participants
@OutcastZeroOne
Copy link

commented Aug 3, 2014

nothing major to report, Just the Pressure Converter not showing up in the creative mode invintory. you have to craft it.

Also the steam whistle is very quiet. If I am 1-2 blocks away its loud. But if I go more then 5-6 blocks away its very quiet. Kind of defeats the purpuse of a warning system when you cant hear it. :/

The fan also will not show up in an item frame. Im guessing cause its a half block?

@Zenith-One

This comment has been minimized.

Copy link
Contributor

commented Aug 3, 2014

Pressure Converter should only show up in creative if fluid steam is registered by another mod. We should probably either enable it all the time or remove the book entry and just not register the item otherwise.

Steam whistle being quiet when farther away may not be something we can control. I'll have to look into that.

re: fan not showing up, I'll have to let Flax field that one, as I have no idea.

@OutcastZeroOne

This comment has been minimized.

Copy link
Author

commented Aug 4, 2014

I think the fan in the item frame thing is because of it being a half block. do its there, but mostlikely its behind the frame.

Im also noticing that my steam systems are resetting theselfs a lot. I leave the game, sometimes just changing texture packs, the system will repreasurize on the closed side of the system.

So lets say I have a section closed off with a valve pipe, all pressure released. leave the game, reload or even sometimes change texture pack. I go back to that closed off area and it suddenly has pressure in it, and the main system has lowered as if the entire system was open. Its like the valves sudenly only work if you never leave the game.

@OutcastZeroOne

This comment has been minimized.

Copy link
Author

commented Aug 5, 2014

I got around the sound of the whistle not going far by having multiple whistles. 4 worked relly well.

The issue of the steam sytem repressurising itself past a closed valve is very anyoing. Also, there is a bug with the boiler "On" image. once a peice of fuel is used up, the furnace stops showing being on. like it turns off with the peice of fuel being used up but it keeps working, it just dosent show the animation of flame, or use the "on" texture.

@Flaxbeard

This comment has been minimized.

Copy link
Contributor

commented Aug 5, 2014

We understand the bug is annoying. Telling us that doesn't help us fix it.

@OutcastZeroOne

This comment has been minimized.

Copy link
Author

commented Aug 6, 2014

if it helps, i can try getting video of any future bugs if you wish. i know you guys are busy working on this along with living your lifes. I just want to try and help if I can.

@Zenith-One

This comment has been minimized.

Copy link
Contributor

commented Aug 6, 2014

Just submitting bug reports (along with any console logs that might be relevant) is good enough.

@OutcastZeroOne

This comment has been minimized.

Copy link
Author

commented Aug 8, 2014

ok. just got the 0.25.1 update. refired up my flashboiler in my test world. at about 3/4 preasure the thing blew! took out half my shop. Fine, I wanted to redo some stuff anyway...

finished redoing my shop. quit to make a back up copy of the save, now it crashes when i try to load this world :(

here is post of crash log. Hope it helps.

---- Minecraft Crash Report ----
// Why did you do that?

Time: 8/7/14 8:33 PM
Description: Exception in server tick loop

java.lang.NullPointerException: Exception in server tick loop
at flaxbeard.steamcraft.block.BlockPipe.func_149731_a(BlockPipe.java:367)
at net.minecraft.world.World.func_147447_a(World.java:1197)
at net.minecraft.world.World.func_72933_a(World.java:1000)
at net.minecraft.world.World.func_72842_a(World.java:2386)
at net.minecraft.world.Explosion.func_77278_a(Explosion.java:135)
at net.minecraft.world.WorldServer.func_72885_a(WorldServer.java:911)
at net.minecraft.world.World.func_72876_a(World.java:2352)
at flaxbeard.steamcraft.api.tile.SteamTransporterTileEntity.explode(SteamTransporterTileEntity.java:161)
at flaxbeard.steamcraft.api.steamnet.SteamNetwork.tick(SteamNetwork.java:113)
at flaxbeard.steamcraft.api.steamnet.SteamNetworkRegistry.onTick(SteamNetworkRegistry.java:71)
at cpw.mods.fml.common.eventhandler.ASMEventHandler_24_SteamNetworkRegistry_onTick_ServerTickEvent.invoke(.dynamic)
at cpw.mods.fml.common.eventhandler.ASMEventHandler.invoke(ASMEventHandler.java:51)
at cpw.mods.fml.common.eventhandler.EventBus.post(EventBus.java:122)
at cpw.mods.fml.common.FMLCommonHandler.onPostServerTick(FMLCommonHandler.java:247)
at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:590)
at net.minecraft.server.integrated.IntegratedServer.func_71217_p(IntegratedServer.java:186)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:427)
at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685)

A detailed walkthrough of the error, its code path and all known details is as follows:

-- System Details --
Details:
Minecraft Version: 1.7.10
Operating System: Mac OS X (x86_64) version 10.9.4
Java Version: 1.6.0_65, Apple Inc.
Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Apple Inc.
Memory: 244254792 bytes (232 MB) / 536887296 bytes (512 MB) up to 4286251008 bytes (4087 MB)
JVM Flags: 1 total; -Xmx4096m
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML: MCP v9.05 FML v7.10.18.1180 Minecraft Forge 10.13.0.1180 Optifine OptiFine_1.7.10_HD_A4 4 mods loaded, 4 mods active
mcp{9.05} Minecraft Coder Pack Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available->Available->Available->Available
FML{7.10.18.1180} Forge Mod Loader Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available->Available->Available->Available
Forge{10.13.0.1180} Minecraft Forge Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available->Available->Available->Available
Steamcraft{0.25.1} Flaxbeard's Steam Power Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available->Available->Available->Available
Profiler Position: N/A (disabled)
Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
Player Count: 0 / 8; []
Type: Integrated Server (map_client.txt)
Is Modded: Definitely; Client brand changed to 'fml,forge'

@Flaxbeard

This comment has been minimized.

Copy link
Contributor

commented Aug 8, 2014

Woah, major bug! Fixing!

@OutcastZeroOne

This comment has been minimized.

Copy link
Author

commented Aug 10, 2014

with the 0.25.2 update the leaking steam system issue is back :( so eerytime the chunk the boiler is on unloads, so dose the steam :(

@elifoster

This comment has been minimized.

Copy link
Member

commented Jan 8, 2016

Note that the fun bug is at #163

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.