Update eslint-plugin-requirejs to version 3.0.0 馃殌 #1875

Merged
merged 3 commits into from Oct 26, 2016

Projects

None yet

4 participants

@greenkeeperio-bot
Contributor

Hello lovely humans,

eslint-plugin-requirejs just published its new version 3.0.0.

State Update 馃殌
Dependency eslint-plugin-requirejs
New version 3.0.0
Type devDependency

This version is not covered by your current version range.

Without accepting this pull request your project will work just like it did before. There might be a bunch of new features, fixes and perf improvements that the maintainers worked on for you though.

I recommend you look into these changes and try to get onto the latest version of eslint-plugin-requirejs.
Given that you have a decent test suite, a passing build is a strong indicator that you can take advantage of these changes by merging the proposed change into your project. Otherwise this branch is a great starting point for you to work on the update.

Do you have any ideas how I could improve these pull requests? Did I report anything you think isn鈥檛 right?
Are you unsure about how things are supposed to work?

There is a collection of frequently asked questions and while I鈥檓 just a bot, there is a group of people who are happy to teach me new things. Let them know.

Good luck with your project

You rock!

馃尨


The new version differs by 23 commits .

  • 6ccad54 3.0.0
  • 1609b8d 3.0.0-rc1
  • 3c3290a Docs: Add indicator for fixable rules
  • df166ed New: Export plugin:requirejs/recommended config
  • 506a673 Docs: Format rule list into tables
  • f2bafa4 Refactor to ES6
  • 7426782 Update: Refactor no-dynamic require rule
  • 9c401ba Update: Refactor no-js-extension rule
  • ca2bb1e Update: Refactor one-dependency-per-line rule
  • b2135b6 Update: Refactor no-assign-require rule
  • d36a064 Update: Refactor no-conditional-require rule
  • dda9314 Build: Improve Test Coverage of no-assign-require rule
  • 17cc698 Chore: Extract generic AST functions to own file
  • e664406 Build: Refactor error message creators for amd-function-arity
  • 9bead61 Build: Add wrapper around ESLint RuleTester

There are 23 commits in total. See the full diff.


This pull request was created by greenkeeper.io.

Tired of seeing this sponsor message? 鈿★笍 greenkeeper upgrade

@greenkeeperio-bot greenkeeperio-bot chore(package): update eslint-plugin-requirejs to version 3.0.0
16b14ff
@interactivellama interactivellama temporarily deployed to fuelux-edge-pr-1875 Sep 26, 2016 Inactive
cormacmccarthy added some commits Oct 10, 2016
@cormacmccarthy cormacmccarthy Merge branch 'master' into greenkeeper-eslint-plugin-requirejs-3.0.0
82bc8ad
@cormacmccarthy cormacmccarthy Merge branch 'master' into greenkeeper-eslint-plugin-requirejs-3.0.0
46b9f2d
@cormacmccarthy cormacmccarthy merged commit a551cfb into master Oct 26, 2016

2 checks passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
continuous-integration/travis-ci/push The Travis CI build passed
Details
@swilliamset swilliamset deleted the greenkeeper-eslint-plugin-requirejs-3.0.0 branch Oct 26, 2016
@cormacmccarthy cormacmccarthy modified the milestone: 3.15.8, 3.15.9 Nov 22, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment