Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Access to Relationship Field values via single related entries tag form not working after EE 5.1.3 -> EE 5.2.0 upgrade #154

Closed
jcogs-design opened this Issue Mar 10, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@jcogs-design
Copy link

jcogs-design commented Mar 10, 2019

Description of the problem
After a routine / one-click update from EE 5.1.3 to EE 5.2.0 a template that used the short form tag for "Single Related Entries" stopped working - returning the tag in place of the required value.

Updating template to use the standard relationship tag pair solved issue, but indicative of an issue (and if a permanent change a need to change relevant EE documentation

How To Reproduce
Error occured on retrieval of a conventional single-use relationship tag.

Error Messages
No Error message - just template tag appearing in output.

Screenshots / Videos / Template Code
This code failed:
{product_series:entry_id}
where product_series is a single-value relationship field in a channel, and the tag is returning the entry_id value for the related entry.

This code modification restored normal working in the template:
{product_series}{product_series:entry_id}{/product_series}

Environment Details:

  • Version: 5.2.0
  • PHP Version 7.2
  • MySQL Version 5.7.16
  • OS: Linux
  • Web Server: Apache

Possible Solution

Additional context

@jcogs-design jcogs-design changed the title Access to "Single Related Entries" not working after EE 5.1.3 -> EE 5.2.0 upgrade Access to Relationship Field values via single tag form not working after EE 5.1.3 -> EE 5.2.0 upgrade Mar 10, 2019

@jcogs-design jcogs-design changed the title Access to Relationship Field values via single tag form not working after EE 5.1.3 -> EE 5.2.0 upgrade Access to Relationship Field values via single related entries tag form not working after EE 5.1.3 -> EE 5.2.0 upgrade Mar 10, 2019

@kevincupp

This comment has been minimized.

Copy link
Contributor

kevincupp commented Mar 11, 2019

Sorry for the trouble, it looks to have been caused by this: a291390

I'm going to revert that change and fix the original issue it was trying to fix another way.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.