Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 32 lines (25 sloc) 1.059 kb
cc2beeb Despo Pentara updated README and created gem
despo authored
1 $:.push File.expand_path("../lib", __FILE__)
2 require "prickle/version"
3
4 Gem::Specification.new do |s|
5 s.name = "prickle"
6 s.version = Prickle::VERSION
7 s.platform = Gem::Platform::RUBY
8 s.author = "Despo Pentara"
9 s.email = "despo@extractmethod.com"
10 s.homepage = "https://github.com/ExtractMethod/prickle"
a5e4f14 Despo Pentara updating description and summary
despo authored
11 s.summary = "A simple DSL extending Capybara."
12 s.description = "A simple DSL extending Capybara."
cc2beeb Despo Pentara updated README and created gem
despo authored
13 s.required_ruby_version = '>= 1.9.2'
14
15 s.licenses = ["MIT"]
16
17 s.files = `git ls-files`.split("\n")
18 s.test_files = `git ls-files -- {spec}/*`.split("\n")
19 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
20 s.require_paths = ["lib"]
21
22 s.add_dependency "capybara"
23
e20fb37 Despo Pentara prickle now works for Capybara and Capybara 2
despo authored
24 s.add_development_dependency "capybara"
00c7def Despo Pentara upgrade rspec
despo authored
25 s.add_development_dependency "rspec", "~> 2.13.0"
cc2beeb Despo Pentara updated README and created gem
despo authored
26 s.add_development_dependency "sinatra", "~> 1.3.2"
6a9a387 Despo Pentara adding rake to dependencies
despo authored
27 s.add_development_dependency "rake"
29fa8cc Despo Pentara adds capybara-webkit popup support
despo authored
28 s.add_development_dependency "capybara-webkit"
ca2a370 Despo Pentara adding reek as a development dependency
despo authored
29 s.add_development_dependency "reek"
cc2beeb Despo Pentara updated README and created gem
despo authored
30 end
31
Something went wrong with that request. Please try again.