Releases: F5Networks/f5-appsvcs-extension
Release list
v3.56.0
Updated the documentation for AS3 v3.56.0. See the Document revision history for more information and links.
This release contains the following changes:
- Support for JSON profiles, Example
- Support for SSE profiles, Example
- (Github Issue 931) AS3 support for X25519MLKEM768 Example
- Add example of MCP iRule with SSE and JSON profiles Example
- (Github Issue 810) AS3 will now ship with a separate consolidated schema file for validation against per-application declarations
- (Github Issue 218) Expand available settings for Bot Defense Example
- Implement AS3 feature to set option for authenticationMode for sub sni profiles, Example
- DOS_Profile will now not create a bot defense profile if the new property application.botDefense.createBotDefenseProfile is set to false.
The following issues have been resolved:
- (Github Issue 935) Duplicate node name error
- (Github Issue 903) Fix provided for AS3 issue 903 does not work with certificate nameingScheme
- Issue enabling OCSP Stapling with ECC Certificates
- (Github Issue 929) L4_Profile idleTimeout property does not accept "immediate", "indefinite", or 0
- Changing HTTPS Monitor to (TCP, TCP-HALF-OPEN, or UDP) adds "user-defined CIPHERLIST DEFAULT" (DUP ID1694621)
- Github Issue 859) Wrong traffic policy rule for the declared one to insert X-Forwarded-Proto header with "http" value
- (Github Issue 943) SNAT_Translation ipIdleTimeout tcpIdleTimeout udpIdleTimeout values are not updated when deployed using per-app
- Invalid Virtual Address, the IP address already exists, Example
- Cannot specify the "/Common/udp" Pool monitor with the string shortcut "udp"
- AS3 per-app deployment fails when there is existing cipherGroup configured
- (Github Issue 943) Invalid characters in published schema may break tools trying to read it
v3.55.0
Updated the documentation for AS3 v3.55.0. See the Document revision history for more information and links.
This release contains the following changes:
- Allow Modification of iFile Content via AS3, Example
- Unable to assign DOS profile as LTM policy action, Example
- (Github Issue 476) Deploy multiple certificates into a single ClientSSL profile Example
- Support PPTP Profile Example.
- Add Support for serversslUseSni Option in Virtual Server Configuration Example
- Support to mask profiles in Constants class Example
- Add Class to create IP-Intelligence policies - AS3 (Github Issue 668)Example
- (Github Issue 684) Support Service Profiles Example.
- Support Splitsession Client Profiles Example.
- (Github Issue 683) Support Connector Profiles Example.
- Optimize the post process ASM call in AS3.
- Update to Service Discovery 1.24.0-7 to address package dependency cves
The following issues have been resolved:
- GTM pools issues after POST GTM servers via AS3
- (Github Issue 840) GSLB_Server - Using 'label' or 'remark' will not set Device name.
- LTM policy rule condition for "geoip" not work in event "client-accepted"
- (Github Issue 558) DOS_Profile.application.stressBasedDetection.badActor - Use TLS patterns as part of host identification, Example.
- (Github Issue 895) Cannot change Pool from FQDN to IP if the node IPs are the same. Continuation of #572.
- Fails to remark LTM pool member
- (Github Issue 873) LTM "legacy" policy automatically adds "requires { http }" and it breaks the customer's AS3 use case
- (Github Issue 872) VirtualAddresses w/mask plus shareAddresses true not idempotent
- (Github Issue 699) Unable to delete AS3 tenant because of irule dependency issue
- Escaped characters in declaration cause AS3 to deploy changes when same declaration is applied again.
- (Github Issue 919) Declaring the same pool member server name multiple times validates, but only uses the last IP address and does not error out
- "ignoreChanges" parameter is ignored when externalFilePath URL has query string
- Unable to create node when same IP SNAT Translation exists
- (Github Issue 863): WAF_Policy: allow use of policy/use referring an existing ASM Policy on the BIG-IP, Example.
- (Github Issue 903) AS3 is ignoring SNIdefault flag
- The serverTLS profiles are not handled correctly when an array of TLS_Server objects is provided in the declaration on the Virtual Server.
- (Github Issue 802) AS3 GitHub issue 802 possible regression
- Creation of Traffic Matching Criteria ignores Destination Port Inline
- (Github Issue 732) Cant rename virtual server. Experiencing code 422 Declaration failed
v3.54.2
The documentation for AS3 v3.54.2, see the Document revision history for more information and links.
This release contains the following changes:
- Introduced a new parameter(Common_0) in the AS3 response trace to monitor the Second Pass execution
- Updated to Service Discovery 1.24.0-1
Issues Resolved:
- (Github Issue 920) Irule parsing error when multiple irules are passed in AS3 declaration
- (Github Issue 908) When declaring multiple certificates, Require Peer SNI support is inconsistently configured
- (Github Issue 914) controls.dryRun=true is not working with configuration on per-application basis
v3.54.1
The documentation for AS3 v3.54.0, see the Document revision history for more information and links.
Note: The v3.54.0 and v3.54.1 refer to the same AS3 LTS v3.54.0 release.
This release contains the following enhancements :
- Service Discovery package bump up to 1.23.0-1
- (Github Issue 112) Monitor will get added to node same like pool monitors, Example.
- Create and reference multiple TLS profiles with a single declaration listing
- Updating Pool Members Without Disrupting Active Connections or Monitor States
- (Github Issue 865) Ability to create a custom BIG-IP type GSLB monitor with AS3, Example.
- (Github Issue 887)[AS3] Add support for oneconnect-status-reuse in http profile via AS3 #887, Example.
Issues Resolved:
- Pool member changing from 443 to 80 (no SSL) - Unexpected paramater appear in created http monitor
- (Github Issue 871) Can't use "requireSNI" property
- AS3 declaration fails with error 0107176c:3: Invalid Virtual Address, the IP address X%X already exists
- Github Issue 885) GSLB WideIP - "poolsCname" object is not allowed along with "pools", Example.
- Unable to create the GSLB_Data_Center object if the prober pool does not exist.
- AS3 CLI SCRIPT responds with very minimal information
- AS3 Declaration for data group with ipv6 addresses fails when no mask is specified
- Escape characters are getting added to actions for LTM Policy creation
- When "bigip" is used with "virtualAddresses" it picks up wrong IP
- [AS3] Unable to rename GSLB Monitor through AS3
v3.53.0
Updated the documentation for AS3 v3.52.0. See the Document revision history for more information and links.
This release contains the following changes:
- Updates to Service Discovery 1.22.0-1
- (Github Issue 827) Minimum Monitors for Members in Class Pool also support "all" value, Example.
- (Github Issue 839) Allow multiple devices in GSLB_Server if the server type is generic-host, Example
- Add support to assign HTTP/2 Profile without TLS to VIP, Example
- (Github Issue 860) Added AS3 schema profilePingAccess for service_HTTP(S) classes similar to existing schema profileAccess, Example1, Example2.
- (Github Issue 844) Firewall rules without the use of address and port lists, Example
- (Github Issue 837) Added AS3 schema minimumMonitors support for GSLB_Servers and GSLB_Virtual_Server classes, Example.
- (Github Issue 837) Author PingAccess Profile and PingAccess Agent Properties via AS3 schema Example, Example2, Example3, Example4.
- (Github Issue 843) GSLB_Monitor - Added Additional Monitor Types(mysql, sip, ldap, smtp), Example for MySql, Example for sip, Example for Ldap, Example for smtp.
- Introduction of the encodeDeclarationMetadata AS3 setting option to encode declaration metadata prior to storing it in a data group.
Issues Resolved:
- The requested SNAT Translation () already exists in partition
- Handle empty values for class UpdaterRest
- (Github Issue 857) Add support for RouteDomain identifer for virtual-address name, Example
- (Github Issue 856) Convert TTL property value to D:H:M:S format, Example
- AS3 use on GTM dramatically reduces device capacity
v3.52.0
Updated the documentation for AS3 v3.52.0. See the Document revision history for more information and links.
This release contains the following changes:
- Add Support for RouteDomain created manually under custom Tenant, Example
- Add Support for “client-accepted” value under "Policy_Action_Drop" object, Example
- Add support for authentication-depth property under TLS_Server and TLS_Client Object, Example
- Add support for pvaAcceleration property under L4_Profile Object, Example
- (GitHub Issue 812) Add support for Notify Certificate Status to Virtual Server, Example
- (Github Issue 836) Enable support for a null monitor when the server type is set to generic-host for GSLB_Server.
- (GitHub Issue 841) Add Support for GSLB monitor TCP Half open monitor type, Example
- Eliminated the need for an SSL profile for virtual servers utilizing passthrough termination for HTTP/2.
- Allow member order for GSLB_Pool Members of resource record type 'A'.
Issues Resolved:
- Fixed the error "The requested Pool Member was not found"
- Fixed the error "Declaration failed with default_mon_tcp is in use"
- (GitHub Issue 829) Support virtualAddresses having suffix of routeDomain 0 in Tenant with non-zero defaultRouteDomain, Example
- (GitHub Issue 793) Add support for setting both client and server http2 profile at the same time, Example
- (GitHub Issue 828) Cosmetic issues in in-progress tasks returned payload typo err fixed and added additional keys with response declarationId and selfLink
v3.51.0
Updated the documentation for AS3 v3.51.0. See the Document revision history for more information and links.
This release contains the following changes:
- Added Support for the serverScope attribute under Service_Address Class, Example.
- Enhanced performance in GTM processing.
- Host, DeclarationID, and tenant info have been included in a failed declaration response.
Issues Resolved:
- SNAT translation address is still referenced by SNAT GitHub Issue 822.
- Changing the VirtualServer name causes changes to the VirtualAddress properties.
- The Poolmember modification and creation is supported in the same declaration.
- Ensure that monitor names are handled correctly.
- Configuring secrets in AS3 may potentially leak them when sharing a qkview/ucs (cert private keys).
- The SSL key is not applied to the DNS https monitor.
v3.50.2
Important: Starting from AS3 version 3.50, AS3 no longer supports BIG-IP 13.1 to 14.1.x. However, if you are still using the BIG-IP 13.1 to 14.1.x versions, you can still use AS3 3.49.0 or earlier.
Updated the documentation for AS3 v3.50.2. See the Document revision history for more information and links.
This release contains the following changes:
- Update new SD task hash collision checks to minimize task churn, when updating from most AS3 versions.
- Updates to Service Discovery 1.19.0-1
- Improve task discovery performance
v3.50.1
Important: Starting from AS3 version 3.50, AS3 no longer supports BIG-IP 13.1 to 14.1.x. However, if you are still using the BIG-IP 13.1 to 14.1.x versions, you can still use AS3 3.49.0 or earlier.
Updated the documentation for AS3 v3.50.1. See the Document revision history for more information and links.
This release contains the following changes:
- Updated task hash collision checks to minimize task churn for users upgrading from v3.48.X and v3.49. A separate release to follow for users upgrading from versions v3.47 and below.
- Removed node 4 testing due to the end of support for BIG-IP 13.1 : (Supported BIG-IP Versions)
- Record first and second passes of Common in separate trace files.
- Update per-app for GA.
- A DELETE to a Tenant or an Application with per-app will now use the previous declaration's
schemaVersionas the savedschemaVersion. - Updated
declarationIdresponse and logging values in non-POST requests. - Tasks are now updated immediately after a PATCH request.
- Updated packages to latest available versions (including Service Discovery 1.18.0-2).
Issues Resolved:
- Endpoint_Policy action clientSsl does not error or set the false value when
enableis specified instead ofenabled. To help users who haveenablein production, either property name will now be acceptable. (GitHub Issue 802) - Service-discovery deletes the pool members for each SD (Service Discovery) modification. (GitHub Issue 788)
- Updating only a
Pool_Member adminStatecreates two consecutive deletes before the tmsh transaction. - Unable to use 10.0.0.0/8 as a virtual address. (GitHub Issue 740)
- Topology Records created in /Common/Shared are being unintentionally deleted.
- Topology Records created in places other than /Common/Shared are being unintentionally deleted. (GitHub Issue 791)
dryRundoes not work when specified in Tenant level controls.
v3.49.0
Updated the documentation for AS3 v3.49.0. See the Document revision history for more information and links.
This release contains the following changes:
- GSLB_Pool with resource record type NAPTR. Only supports flags value of 'a' for members
- Add handshakeTimeout to TLS_Server and TLS_Client (GitHub Issue 756)
- GSLB_Domain with resource record type NAPTR
- GSLB_Domain load-balancing decision log property (GitHub Issue 772)
- Invalid default setting for request/response chunking (sustain) in HTTP_Profile on TMOS v15.0+ (GitHub Issue 512)
- Expose SNI for GSLB HTTPS monitor (GitHub Issue 778)
- Add the declaration id to the restnoded log output upon success and include it in the rest response
- Expose failureRcode properties for GSLB WideIP
- GSLB_Monitor HTTP/HTTPS receiveStatusCodes property (GitHub Issue 779)
- Add routeDomainEnforcement to Firewall_Policy to allow enforcing the Firewall_Policy on the specified Route Domain's (GitHub Issue 321)
Issues Resolved:
- All pool member statuses reset to unknown when new member is added to the pool
- Certain AS3 declarations result in
declaration has duplicate valueserrors - Schema validation failure when declaring ICMP Monitor with targetPort or any Monitor with additional properties
- Can't use x.x.1 schemaVersion accepted by schema that is x.x.1 codified (GitHub Issue 677)