Skip to content

  • fix: improve support for Confocor FCS file format
    (see discussion in #37)
  • ref: make pathlib.Path a standard in readfiles
  • code cleanup
  • drop support for Python<3.6
Assets 4

@paulmueller paulmueller released this Nov 27, 2018 · 14 commits to develop since this release

  • docs: fix build with recent version of latex (#191)
Assets 4

@paulmueller paulmueller released this Jul 23, 2018 · 19 commits to master since this release


Maintenance release.

Assets 4
Pre-release
Pre-release

@paulmueller paulmueller released this Jul 22, 2018 · 21 commits to master since this release


Maintenance release.

Assets 2
Pre-release
Pre-release

@paulmueller paulmueller released this Jul 22, 2018 · 23 commits to master since this release

  • ci: Automated release to PyPI with appveyor and travis-ci
  • fix: support lmfit >= 0.9.11
Assets 4

@paulmueller paulmueller released this May 29, 2018 · 35 commits to master since this release

  • Fix plotting error with LaTeX (thanks @toubol) (#179)
  • Update documentation
Assets 9

@paulmueller paulmueller released this May 27, 2018 · 44 commits to master since this release

  • BREAKING CHANGE: Move to Python3 (thanks @toubol) (#173)
  • GUI:
    • Add option in Preferences to automatically close tools after usage
    • Add keyboard shortcuts (thanks @toubol)
  • Fix entry point for GUI (#172)
  • Refactor several asserts into raises
Assets 9

@paulmueller paulmueller released this Aug 28, 2017 · 88 commits to master since this release

  • Improved support for ALV ".ASC" file format (#169)
  • NumPy 0.13 support for ".ptu" file reader
  • Code cleanup:
    • Fetch latest available version from GitHub releases
    • New dependency for "simplejson" Python package
    • Move appveyor recipe to separate folder
Assets 11

@paulmueller paulmueller released this Jul 17, 2016 · 123 commits to master since this release

As of this release, PyCorrFit does not anymore require administrative rights during installation. Before upgrading to this version, please uninstall the previous version (administrative rights required).

  • Remove admin-requirement during install (Windows)
  • Support newer correlator.com .sin file format (experimental, #135)
  • Add smart progress dialog for fitting (#155)
  • Statistics: check "filename/title" by default (#151)
  • Documentation: fix bad LaTeX commands (#163)
Assets 8
You can’t perform that action at this time.