Skip to content
Permalink
Browse files

Prevent from moving from MySQL 5.7 to MariaDB on Ubuntu as it's not p…

…roperly supported yet and causes the old database to be moved to /var/lib/mysql-5.7 and makes users think the DB is gone.
  • Loading branch information...
Sebastian-Roth committed Jul 30, 2019
1 parent 9ff8776 commit 29af4df767775e08fc102ea1cf61b4da789b61d5
Showing with 8 additions and 2 deletions.
  1. +7 −1 lib/ubuntu/config.sh
  2. +1 −1 packages/web/lib/fog/system.class.php
@@ -68,7 +68,13 @@ elif [[ $linuxReleaseName == +(*[Uu][Bb][Uu][Nn][Tt][Uu]*|*[Mm][Ii][Nn][Tt]*) ]]
phpcmd="php"
libcurl="libcurl3";
[[ $OSVersion -ge 18 ]] && libcurl="libcurl4"
packages="apache2 build-essential cpp curl g++ gawk gcc genisoimage gzip htmldoc isc-dhcp-server isolinux lftp libapache2-mod-fastcgi libapache2-mod-php${php_ver} libc6 $libcurl liblzma-dev m4 mariadb-client mariadb-server net-tools nfs-kernel-server openssh-server $phpfpm php-gettext php${php_ver} php${php_ver}-cli php${php_ver}-curl php${php_ver}-gd php${php_ver}-json $phpldap php${php_ver}-mysql php${php_ver}-mysqlnd sysv-rc-conf tar tftpd-hpa tftp-hpa vsftpd wget xinetd zlib1g"
x="mysql-server"
eval $packageQuery >>$workingdir/error_logs/fog_error_${version}.log 2>&1
if [[ $? -eq 0 ]]; then
packages="apache2 build-essential cpp curl g++ gawk gcc genisoimage gzip htmldoc isc-dhcp-server isolinux lftp libapache2-mod-fastcgi libapache2-mod-php${php_ver} libc6 $libcurl liblzma-dev m4 mysql-client mysql-server net-tools nfs-kernel-server openssh-server $phpfpm php-gettext php${php_ver} php${php_ver}-cli php${php_ver}-curl php${php_ver}-gd php${php_ver}-json $phpldap php${php_ver}-mysql php${php_ver}-mysqlnd sysv-rc-conf tar tftpd-hpa tftp-hpa vsftpd wget xinetd zlib1g"
else
packages="apache2 build-essential cpp curl g++ gawk gcc genisoimage gzip htmldoc isc-dhcp-server isolinux lftp libapache2-mod-fastcgi libapache2-mod-php${php_ver} libc6 $libcurl liblzma-dev m4 mariadb-client mariadb-server net-tools nfs-kernel-server openssh-server $phpfpm php-gettext php${php_ver} php${php_ver}-cli php${php_ver}-curl php${php_ver}-gd php${php_ver}-json $phpldap php${php_ver}-mysql php${php_ver}-mysqlnd sysv-rc-conf tar tftpd-hpa tftp-hpa vsftpd wget xinetd zlib1g"
fi
apt-get clean -yq >/dev/null 2>&1
echo "Done"
;;
@@ -53,7 +53,7 @@ private static function _versionCompare()
public function __construct()
{
self::_versionCompare();
define('FOG_VERSION', '1.5.7.1');
define('FOG_VERSION', '1.5.7.2');
define('FOG_SCHEMA', 267);
define('FOG_BCACHE_VER', 133);
define('FOG_SVN_REVISION', 6080);

0 comments on commit 29af4df

Please sign in to comment.
You can’t perform that action at this time.