PHP API CLIENT Jortt BV
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.gitattributes
.travis.yml
LICENSE
README.md
class.jorttbv.php
composer.json

README.md

Jortt API client for PHP

PHP WEB API JSON for Jortt B.V

Build Status Floobits Status Dependency Status Scrutinizer Code Quality SensioLabsInsight

Requirements

To use the Jortt API client, the following things are required:

  • Visit website for free Jortt account
  • Create a new profile to generate API keys
  • PHP 5.2 or 5.5
  • PHP cURL extension

Easy way to install the Jortt BV API client is to require it with Composer.

$ composer require fabricedelahaij/jorttbv-php-api:1.0.*

{ "require": { "fabricedelahaij/jorttbv-php-api": "1.0.*" } }

Getting started

require_once('class.jorttbv.php'); 

define('APPID', 'DEMO');
define('APPTOKEN', '000-000-000');

$api = new JorttBV_Client(APPID, APPTOKEN);
$data = [
	'customer' => [
		'company_name' => '',
		'attn' => '',
		"email" => '',
		'extra_information' => '',
		'invoice_language' => NL,
		'address' =>[
		        'street' => '',
			'postal_code' => '',
        		'city' => '',
        		'country_code' => NL
		]
	]
];
$api->request($data, 'customers');

API documentation

If you wish to learn more about our API, please visit the API Documentation.

License

BSD (Berkeley Software Distribution) License. Copyright (c) 2017, Extreemhost.

Support

Contact: www.extreemhost.nl — info@extreemhost — +31 316-23 40 40