Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Routing Error #11

Closed
devinhalladay opened this Issue Feb 10, 2013 · 13 comments

Comments

Projects
None yet
4 participants

I'm finally to the point where I can run rails s. However, after I run it, I visit localhost:3000 and get this error:

Routing Error

No route matches {:action=>"show", :format=>:rss, :controller=>"members"}
Try running rake routes for more information on available routes.

Any ideas on how to fix this?
Here's the console output:

nivedred@NivedRed-Ubuntu:~/Simvla-Network$ rails s 
=> Booting WEBrick
=> Rails 3.2.1 application starting in development on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
[2013-02-10 17:21:29] INFO  WEBrick 1.3.1
[2013-02-10 17:21:29] INFO  ruby 1.8.7 (2011-06-30) [x86_64-linux]
[2013-02-10 17:21:34] INFO  WEBrick::HTTPServer#start: pid=3986 port=3000


Started GET "/" for 127.0.0.1 at Sun Feb 10 17:21:37 -0500 2013
Processing by LandingController#index as HTML
   (4.0ms)  SELECT COUNT(*) FROM `users` WHERE `users`.`external_domain` = '0.0.0.0'

 users 0

  CACHE (0.0ms)  SELECT COUNT(*) FROM `users` WHERE `users`.`external_domain` = '0.0.0.0'
  User Load (0.2ms)  SELECT `users`.* FROM `users` INNER JOIN `roles_users` ON `roles_users`.`user_id` = `users`.`id` INNER JOIN `roles` ON `roles`.`id` = `roles_users`.`role_id` WHERE `users`.`is_enabled` = 1 AND (roles.alias = 'User') ORDER BY created_at desc LIMIT 1000
  Rendered layouts/shared/_footer.html.erb (0.5ms)
  Rendered members/fe/index.html.erb within layouts/application (494.0ms)
  Rendered layouts/shared/_head.html.erb (305.3ms)
  User Load (1.2ms)  SELECT `users`.* FROM `users` WHERE `users`.`email` = 'admin@simvla.com' LIMIT 1
  Rendered layouts/shared/_header.html.erb (16.6ms)
Completed 500 Internal Server Error in 911ms

ActionController::RoutingError (No route matches {:action=>"show", :format=>:rss, :controller=>"members"}):
  app/helpers/url_helper.rb:12:in `url_for'
  app/views/layouts/shared/_header.html.erb:14:in `_app_views_layouts_shared__header_html_erb___1402626765_69985835290220'
  app/views/layouts/application.html.erb:11:in `_app_views_layouts_application_html_erb__1511007136_69985835018360'
  app/controllers/landing_controller.rb:14:in `index'
  app/controllers/landing_controller.rb:4:in `index'


  Rendered /var/lib/gems/1.8/gems/actionpack-3.2.1/lib/action_dispatch/middleware/templates/rescues/routing_error.erb within rescues/layout (0.6ms)


Started GET "/favicon.ico" for 127.0.0.1 at Sun Feb 10 17:21:40 -0500 2013

ActionController::RoutingError (No route matches [GET] "/favicon.ico"):
  actionpack (3.2.1) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
  actionpack (3.2.1) lib/action_dispatch/middleware/show_exceptions.rb:56:in `call'
  railties (3.2.1) lib/rails/rack/logger.rb:26:in `call_app'
  railties (3.2.1) lib/rails/rack/logger.rb:16:in `call'
  actionpack (3.2.1) lib/action_dispatch/middleware/request_id.rb:22:in `call'
  rack (1.4.1) lib/rack/methodoverride.rb:21:in `call'
  rack (1.4.1) lib/rack/runtime.rb:17:in `call'
  activesupport (3.2.1) lib/active_support/cache/strategy/local_cache.rb:72:in `call'
  rack (1.4.1) lib/rack/lock.rb:15:in `call'
  actionpack (3.2.1) lib/action_dispatch/middleware/static.rb:53:in `call'
  railties (3.2.1) lib/rails/engine.rb:479:in `call'
  railties (3.2.1) lib/rails/application.rb:220:in `call'
  rack (1.4.1) lib/rack/content_length.rb:14:in `call'
  railties (3.2.1) lib/rails/rack/log_tailer.rb:14:in `call'
  rack (1.4.1) lib/rack/handler/webrick.rb:59:in `service'
  /usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
  /usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
  /usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
  /usr/lib/ruby/1.8/webrick/server.rb:162:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
  /usr/lib/ruby/1.8/webrick/server.rb:95:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:92:in `each'
  /usr/lib/ruby/1.8/webrick/server.rb:92:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:23:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:82:in `start'
  rack (1.4.1) lib/rack/handler/webrick.rb:13:in `run'
  rack (1.4.1) lib/rack/server.rb:265:in `start'
  railties (3.2.1) lib/rails/commands/server.rb:70:in `start'
  railties (3.2.1) lib/rails/commands.rb:55
  railties (3.2.1) lib/rails/commands.rb:50:in `tap'
  railties (3.2.1) lib/rails/commands.rb:50
  script/rails:6:in `require'
  script/rails:6


  Rendered /var/lib/gems/1.8/gems/actionpack-3.2.1/lib/action_dispatch/middleware/templates/rescues/routing_error.erb within rescues/layout (2.1ms)

Anybody home?

Owner

FaisalAbid commented Feb 14, 2013

@nivedred Thanks for your bug request. I've taken over the project and I will see to it that this bug gets fixed.

Thanks for supporting Simvla!

@FaisalAbid any news on this bug?

Any news?? This bug is driving me crazy.

@FaisalAbid is this project alive?

@devinhalladay devinhalladay reopened this Mar 23, 2013

Owner

FaisalAbid commented Apr 17, 2013

Hey @nivedred - Apologize for the delay. Yes the project is alive. but being heavily re architected. If you want, I can give you access to the private repo we use to deploy simvla.com.

That'd be great! Hopefully that code won't throw the same errors.

laimn commented Jun 12, 2013

This is when the admin user (admin@simvla.com) isn't in the database, so if the admin user wasn't created or if it wasn't created with the email admin@simvla.com - had the same bug but managed to fix it!

Hmm, that's weird. It makes no sense that the admin email must be admin@simvla.com...

Regardless, I'll try that out and let you guys know if it works.

Contributor

duezerouno commented Jun 13, 2013

@laimn @nivedred infact admin[at]simvla[dot]com it's not mandatory. You do need an admin user to manage the whole thing, but that's pretty easy to understand since it uses cancan for roles.

laimn commented Jun 13, 2013

But the admin user is used to generate the rss feed. That's what's throwing the error.

Contributor

duezerouno commented Jun 18, 2013

@laimn yes, but it's not mandatory that it should be admin[at]simvla[dot]com - that's totally wrong!

laimn commented Jun 18, 2013

Yeah, but if that user is not in the database, the email needs to be updated in app/views/layouts/shared/_header.html.erb to the administrators email, or the admin needs to be created. If the email specified in the header file is not in the database, the above error is thrown.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment