Permalink
Browse files

Add eslint script (extends airbnb + react + react-native)

Currently 506 errors, 7 warnings :D
  • Loading branch information...
cooperka committed Dec 21, 2016
1 parent 3078e40 commit 829a7aa1ec31c867bca9ff99688792e943eb6f13
Showing with 22 additions and 16 deletions.
  1. +3 −0 .eslintignore
  2. +9 −13 .eslintrc
  3. +10 −3 package.json
View
@@ -0,0 +1,3 @@
node_modules
android
ios
View
@@ -1,16 +1,12 @@
{
"plugins": [
"react",
"react-native"
],
"extends": ["eslint:recommended", "plugin:react/recommended"],
"parserOptions": {
"sourceType": "module",
"ecmaFeatures" : {
experimentalObjectRestSpread: true
}
},
"extends": "cooperka/react-native",
"env": {
"node": true
}
"browser": true,
"jest": true
},
// Any rules here will override those from
// https://github.com/cooperka/eslint-config-cooperka.
"rules": {}
}
View
@@ -23,10 +23,17 @@
"url": "https://github.com/FaridSafi/react-native-gifted-chat/issues"
},
"homepage": "https://github.com/FaridSafi/react-native-gifted-chat#readme",
"scripts": {
"lint": "eslint . --ext .js,.jsx"
},
"devDependencies": {
"eslint": "^3.2.2",
"eslint-plugin-react": "^6.0.0",
"eslint-plugin-react-native": "^2.0.0"
"eslint": "~3.12.2",
"eslint-config-airbnb": "~13.0.0",
"eslint-config-cooperka": "~0.2.2",
"eslint-plugin-import": "~2.2.0",
"eslint-plugin-jsx-a11y": "~2.2.3",
"eslint-plugin-react": "~6.8.0",
"eslint-plugin-react-native": "~2.2.1"
},
"dependencies": {
"@exponent/react-native-action-sheet": "git+https://github.com/FaridSafi/react-native-action-sheet.git",

0 comments on commit 829a7aa

Please sign in to comment.