Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

0.10.2 breaks ExpoKit compilation #1432

Closed
shamilovtim opened this issue Oct 1, 2019 · 8 comments

Comments

@shamilovtim
Copy link

commented Oct 1, 2019

*Downgraded back to 0.10.0.

switch to react-native-gifted-chat": "^0.10.0" and your expokit app should compile.

@shamilovtim

This comment has been minimized.

Copy link
Author

commented Oct 1, 2019

Please see here for what is most likely the breaking change:

1593c2b

@xcarpentier

This comment has been minimized.

Copy link
Collaborator

commented Oct 1, 2019

No you don’t have to downgrade, you just have to declare expo-av yourself.
Please refer warnings on installation or simply peerDependecies you have to declare yourself.

@shamilovtim

This comment has been minimized.

Copy link
Author

commented Oct 2, 2019

The instructions say no expo and the error thrown is for expo-av, which the readme says specifically isn't being used. Adding react-native-video doesn't fix the issue. Not sure I'm understanding

@xcarpentier

This comment has been minimized.

Copy link
Collaborator

commented Oct 2, 2019

Does it fix your issue if you declare expo-av and react-native-video into your dependencies?

@alexandrius

This comment has been minimized.

Copy link

commented Oct 3, 2019

I too experience the problem. I don't want to add the library which I'm not using. I'm thinking to just fork this lib if we are forced to add the expo-av

@alexandrius

This comment has been minimized.

Copy link

commented Oct 3, 2019

@xcarpentier the readme mentions "No expo, no web, just native" and I'm using Expo. I get this error while I should not I guess

@xcarpentier

This comment has been minimized.

Copy link
Collaborator

commented Oct 3, 2019

Ok
I think I will remove both: expo-av and react-native-video tomorrow on a new release. Those are really annoying and we will be able to use customView to provide video support

@alexandrius

This comment has been minimized.

Copy link

commented Oct 3, 2019

@xcarpentier I agree completely. This is amazing library but video is very specific.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.