New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

3.1.8 Release not available in Arduino Library Manager #561

Open
maddogjt opened this Issue Feb 5, 2018 · 3 comments

Comments

Projects
None yet
3 participants
@maddogjt

maddogjt commented Feb 5, 2018

The Arduino library manager is still only showing the 3.1.6 release, although it looks like work was done to publish a 3.1.8 release.

I'm not familiar with the library release process, but according to the docs that I found here, library.properties may be in need of an update.

@kriegsman

This comment has been minimized.

Contributor

kriegsman commented Feb 5, 2018

Thank you, I’ll get on that ASAP.

@per1234

This comment has been minimized.

Contributor

per1234 commented Feb 8, 2018

The library.properties version value must be updated before the tag is created. You would need to either redo the 3.1.8 tag or release a new version.

The same issue is also the cause of 3.1.7 not being available in Library Manager:
https://github.com/FastLED/FastLED/blob/3.1.7/library.properties#L2

@kriegsman

This comment has been minimized.

Contributor

kriegsman commented Feb 8, 2018

Yep. I’m going to tag 3.1.9.
And possibly add a checklist file to the library for future releasers so we make sure to update everything all at once. Sorry for the delays; we’ll get it straightened out quickly now.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment