New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Wrong number of LEDs on ws2812b #711

Open
joaovalentee opened this Issue Jan 1, 2019 · 3 comments

Comments

Projects
None yet
3 participants
@joaovalentee
Copy link

joaovalentee commented Jan 1, 2019

Hey guys I have a quick question. I recently bought a ws2812b strip. I firstly tested it with an Arduino and everything worked fine but I really wanted to control it with an ESP32. The problems appeared when I tried the ESP32.
My strip has 300 leds but I want to control only 90. But when I define the NUM_LEDS 90 somehow more than 90 leds turn on. Can’t understand why.
Thanks.

@RococoN8R

This comment has been minimized.

Copy link

RococoN8R commented Jan 1, 2019

@joaovalentee

This comment has been minimized.

Copy link

joaovalentee commented Jan 2, 2019

I just used the DemoReelESP32 example to test it but I'm still having the same problem. The only thing I changed was the number of LEDs and by testing it again I realised that it's happening like the strip is duplicating the process. When I define the NUM_LEDS 90 at the same time as it considers the first led the number 1, also considers the 91 led the number 1! And applies the code to 90 leds afeter those 2 at the same time.

@marcmerlin

This comment has been minimized.

marcmerlin added a commit to marcmerlin/FastLED that referenced this issue Jan 5, 2019

Delete delete confusing demo.
- standard demoreeel works on ESP32 now
- FastLED#711 says this demo worked
  badly.
- FastLED#713 says it's incompatible
  with Wifi.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment