Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FastLed cause program stop functioning #792

Open
yaronze opened this issue May 15, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@yaronze
Copy link

commented May 15, 2019

i am using Arduino nano & tested with Uno too, using FastLed library.
the project includes SD module and serial communication via USB.
when i put the line -FastLED.addLeds<NEOPIXEL,DATA_PIN>(leds, NUM_LEDS); starts very strange behaviors like - part of the program not running as suppose too, sometimes reset the nano with no reasonable cause.
when i make this code line as comment - all problems go away and everything work s fine.
what is the problem with the FastLeds? are there any conflict with other libraries or hardware?
thanks

@focalintent

This comment has been minimized.

Copy link
Member

commented May 18, 2019

It's hard to say without seeing what the rest of your code is like. It's possible you're running into issues with interrupts. It's possible you're running out of memory. It's possible that you have a memory corruption issue somewhere that's corrupting memory only used by FastLED, so when you comment out the addLeds line FastLED is effectively not doing anything, and therefor not hitting it.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.