Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Does not compile for STM32F103 blue-pill #805

Open
Kashouryo opened this issue May 25, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@Kashouryo
Copy link

commented May 25, 2019

tested on the newest master branch, with STM32duino 1.5.

In file included from C:\Software\Arduino IDE\portable\sketchbook\libraries\FastLED/led_sysdefs.h:32:0,
from C:\Software\Arduino IDE\portable\sketchbook\libraries\FastLED/FastLED.h:41,

             from C:\Users\think\AppData\Local\Temp\arduino_modified_sketch_17966\Blink.ino:1:

C:\Software\Arduino IDE\portable\sketchbook\libraries\FastLED/platforms/avr/led_sysdefs_avr.h:12:20: fatal error: avr/io.h: No such file or directory
#include <avr/io.h>

                ^

compilation terminated.

@markopl96

This comment has been minimized.

Copy link

commented Jun 22, 2019

I'm using platformIO and I'm getting the same error, did someone found solution for that?

It's looks for me like the library has some hardcoded #include from avr, coz when I compiled the same code from platformIO in ArduinoIDE where I have instaled avr and stm32 boards it compiled fine.

@Kashouryo what IDE are you using? if arduino try to install avr and stm32 cores.

Was sm able to run FastLED with STM32 in platformIO?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.