Browse files

Fixed sc-docs warning

  • Loading branch information...
1 parent bffe700 commit 90eca6e1cd3dee6646964c14ab3f9c0bc0887eb8 @wagenet wagenet committed May 24, 2011
Showing with 7 additions and 8 deletions.
  1. +6 −1 bin/sc-docs
  2. +1 −7 lib/sproutcore/tools/docs.rb
View
7 bin/sc-docs
@@ -9,6 +9,11 @@
require "sproutcore"
-SC::Tools.invoke :docs
+begin
+ require 'sc_docs/cli'
+ ScDocs::CLI.start
+rescue LoadError
+ puts "sc-docs is no longer bundled with SproutCore. Please install the sc-docs tool instead."
+end
# EOF
View
8 lib/sproutcore/tools/docs.rb
@@ -10,15 +10,9 @@
module SC
class Tools
-
desc "docs [TARGET..]", "Generates JSDoc's for specified targets."
def docs
- begin
- require 'sc_docs/cli'
- ScDocs::CLI.start
- rescue LoadError
- puts "sc-docs is no longer bundled with SproutCore. Please install the sc-docs tool instead."
- end
+ puts "Doc generation is no longer bundled with SproutCore. Please install the sc-docs tool instead."
end # def docs
end # class Tools
end # module SC

0 comments on commit 90eca6e

Please sign in to comment.