Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

Octocat-spinner-32 bin
Octocat-spinner-32 design
Octocat-spinner-32 lib
Octocat-spinner-32 rails
Octocat-spinner-32 spec
Octocat-spinner-32 .gitignore
Octocat-spinner-32 .kick
Octocat-spinner-32 README.rdoc
Octocat-spinner-32 Rakefile
Octocat-spinner-32 TODO
Octocat-spinner-32 VERSION
Octocat-spinner-32 apprise.gemspec
README.rdoc

Apprise!

Apprise looks at your Ruby on Rails application and tried to figure out all the dependencies of the project and which ones are outdated.

Apprise currently looks for three types of dependencies.

  • Gems specified in the Gemfile

  • Git checkouts of plugins in vendor/plugins

  • Subversion checkout of plugins in vendor/plugins

Using Apprise as a Rails plugin

$ ./script/plugin install git://github.com/Fingertips/apprise.git
$ rake deps:outdated

Using Apprise as a gem

$ gem install apprise --source http://gemcutter.org
$ apprise /path/to/rails

Support

Apprise is known to run on Ruby 1.8.7 and 1.9.2.

Something went wrong with that request. Please try again.