Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

erubis error on 1.9.3 #3

Closed
cristibalan opened this Issue · 4 comments

3 participants

Cristi Balan Vesa Vänskä Manfred Stienstra
Cristi Balan

ruby 1.9.3-p0 with the performance patches from someplace
saga 0.8.0
erubis 2.7.0

saga new ohaai                               
(erubis:1:in `format': undefined local variable or method `title' for #<Saga::Formatter:0x007fd1fc30e028> (NameError)
    from /Users/lu/.rbenv/versions/1.9.3-p0-perf/lib/ruby/gems/1.9.1/gems/erubis-2.7.0/lib/erubis/evaluator.rb:65:in `eval'
    from /Users/lu/.rbenv/versions/1.9.3-p0-perf/lib/ruby/gems/1.9.1/gems/erubis-2.7.0/lib/erubis/evaluator.rb:65:in `result'
    from /Users/lu/.rbenv/versions/1.9.3-p0-perf/lib/ruby/gems/1.9.1/gems/saga-0.8.0/lib/saga/formatter.rb:23:in `format'
    from /Users/lu/.rbenv/versions/1.9.3-p0-perf/lib/ruby/gems/1.9.1/gems/saga-0.8.0/lib/saga/formatter.rb:31:in `format'
    from /Users/lu/.rbenv/versions/1.9.3-p0-perf/lib/ruby/gems/1.9.1/gems/saga-0.8.0/lib/saga/formatter.rb:39:in `saga_format'
    from /Users/lu/.rbenv/versions/1.9.3-p0-perf/lib/ruby/gems/1.9.1/gems/saga-0.8.0/lib/saga/runner.rb:47:in `new_file'
    from /Users/lu/.rbenv/versions/1.9.3-p0-perf/lib/ruby/gems/1.9.1/gems/saga-0.8.0/lib/saga/runner.rb:88:in `run_command'
    from /Users/lu/.rbenv/versions/1.9.3-p0-perf/lib/ruby/gems/1.9.1/gems/saga-0.8.0/lib/saga/runner.rb:107:in `run'
    from /Users/lu/.rbenv/versions/1.9.3-p0-perf/lib/ruby/gems/1.9.1/gems/saga-0.8.0/lib/saga.rb:16:in `run'
    from /Users/lu/.rbenv/versions/1.9.3-p0-perf/lib/ruby/gems/1.9.1/gems/saga-0.8.0/bin/saga:5:in `<top (required)>'
    from /Users/lu/.rbenv/versions/1.9.3-p0-perf/lib/ruby/gems/1.9.1/bin/saga:19:in `load'
    from /Users/lu/.rbenv/versions/1.9.3-p0-perf/lib/ruby/gems/1.9.1/bin/saga:19:in `<main>'
Vesa Vänskä

I have the same problem. Otherwise the same versions but no performance patches.

Manfred Stienstra
Owner

Hey guys, are you still seeing this problem? It works for me on Ruby 1.9.3-p145 with Saga 0.9.1 and Erubis 2.7.0.

Vesa Vänskä

Works for me.

Manfred Stienstra
Owner

Awesome, thanks for your time!

Manfred Stienstra Manfred closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.