Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade ICU to version 52.1 [CORE2224] #2652

Closed
firebird-issue-importer opened this issue Dec 3, 2008 · 11 comments
Closed

Upgrade ICU to version 52.1 [CORE2224] #2652

firebird-issue-importer opened this issue Dec 3, 2008 · 11 comments

Comments

@firebird-issue-importer
Copy link

firebird-issue-importer commented Dec 3, 2008

Submitted by: Miha Vrhovnik (mvrhov)

Votes: 1

Could starting with FB 2.5 default ICU version be at least 3.6? This would bring FB support regarding Unicode to version 5.0.. This would also synchronize dependencies of some Linux packages...

Commits: e6ba3d4 FirebirdSQL/fbt-repository@0317597

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Dec 3, 2008

Commented by: @AlexPeshkoff

Starting with FB 2.1 you can configure firebird with --with-system-icu switch and get access to a version, already installed on your box.

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Dec 3, 2008

Commented by: Miha Vrhovnik (mvrhov)

Mac OS X and Linx are in my 2nd plan, the 1st one is Windows where having a single set of dependencies especially for the ones where C++ is not primary development language.

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Dec 3, 2008

Modified by: @dyemanov

assignee: Adriano dos Santos Fernandes [ asfernandes ]

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Oct 19, 2009

Modified by: @dyemanov

Fix Version: 3.0 Alpha 1 [ 10331 ]

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Apr 13, 2013

Modified by: @dyemanov

Fix Version: 3.0 Beta 1 [ 10332 ]

Fix Version: 3.0 Alpha 1 [ 10331 ] =>

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Feb 12, 2014

Commented by: @mariuz

In ubuntu 14.04 (next LTS) current icu is 5.2 (also firebird is patched in debian to use it)

http://site.icu-project.org/download/52
https://launchpad.net/ubuntu/+source/icu

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Feb 24, 2014

Modified by: @asfernandes

Component: Charsets/Collation [ 10001 ]

Component: Engine [ 10000 ]

summary: Upgrade ICU to at least 3.6 => Upgrade ICU to version 52.1

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Feb 24, 2014

Modified by: @asfernandes

status: Open [ 1 ] => Resolved [ 5 ]

resolution: Fixed [ 1 ]

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Sep 22, 2015

Modified by: @pcisar

status: Resolved [ 5 ] => Closed [ 6 ]

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Jan 19, 2016

Modified by: @pavel-zotov

QA Status: No test

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Aug 12, 2016

Modified by: @pavel-zotov

status: Closed [ 6 ] => Closed [ 6 ]

QA Status: No test => Cannot be tested

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment