Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

The cursor identified in the UPDATE or DELETE statement is not positioned on a row. no current record for fetch operation in SELECT query [CORE3210] #3584

Closed
firebird-issue-importer opened this issue Nov 2, 2010 · 9 comments

Comments

@firebird-issue-importer
Copy link

@firebird-issue-importer firebird-issue-importer commented Nov 2, 2010

Submitted by: Miroslav Djorov (miro)

Attachments:
db.fbk

In this query if you uncomment all 3 lines Firebird gives this errror:
"The cursor identified in the UPDATE or DELETE statement is not positioned on a row.
no current record for fetch operation."
But if you comment one or more of the lines - ORDER BY, the most outer coalesce or the first line the query runs without problems.
Under 2.1.3 there is no problem with the query.

SELECT
-- DEPOZIT.NUMBER || ' ' ||
-- COALESCE(
IIF(NAST.BUL_ID IS NOT NULL, COALESCE(http://BULGARIANS.NAME,'') || ' ' || COALESCE(BULGARIANS.FAMILY,''), COALESCE(FOREIGNERS.NAME_CYR,FOREIGNERS.NAME_LAT))
-- ,'')
AS NAME
FROM
DEPOZIT LEFT JOIN NAST ON http://NAST.ID = DEPOZIT.NAST_ID
LEFT JOIN BULGARIANS ON http://BULGARIANS.ID = NAST.BUL_ID
LEFT JOIN FOREIGNERS ON http://FOREIGNERS.ID = NAST.FOR_ID
--ORDER BY 1

Commits: 85ba1c7

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Nov 2, 2010

Commented by: Miroslav Djorov (miro)

This is a test database for the query.

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Nov 2, 2010

Modified by: Miroslav Djorov (miro)

Attachment: db.fbk [ 11809 ]

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Nov 2, 2010

Modified by: @dyemanov

assignee: Dmitry Yemanov [ dimitr ]

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Nov 2, 2010

Commented by: @dyemanov

Please try with the latest snapshot build.

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Nov 2, 2010

Commented by: Miroslav Djorov (miro)

This is what I've did:
I've downloaded the archive with Firebird-2.5.0.26108 build. I've replaced the files from the original installation with these from the archive. Also I've replaced the fbclient.dll in Windows\system32. But the gds32.dll is the old one from 26074 build. After that I've tried the query but it doesn't work - the error still exists.

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Nov 2, 2010

Commented by: @dyemanov

The fix will be available in the next snapshot build.

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Nov 2, 2010

Modified by: @dyemanov

status: Open [ 1 ] => Resolved [ 5 ]

resolution: Fixed [ 1 ]

Fix Version: 2.5.1 [ 10333 ]

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Feb 4, 2011

Modified by: @pcisar

status: Resolved [ 5 ] => Closed [ 6 ]

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented May 29, 2015

Modified by: @pavel-zotov

status: Closed [ 6 ] => Closed [ 6 ]

QA Status: Done successfully

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants