Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

v3 GBAK cannot restore backups on pre-v3 server versions [CORE4346] #4668

Closed
firebird-issue-importer opened this issue Feb 20, 2014 · 6 comments

Comments

@firebird-issue-importer

Submitted by: @dyemanov

Restore ends with error:

gbak: ERROR:invalid request BLR at offset 201
gbak: ERROR: generator RDB$GENERATOR_NAME is not defined
gbak:Exiting before completion due to errors

Commits: ae658e9 FirebirdSQL/fbt-repository@a69571a

====== Test Details ======

Deferred. Seems test must know where GBAK v3 lives (its FB3 home folder) and must have the port number of FB 2.5 instance.
Currently I have no info how it can be done using fbt_run.

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Feb 20, 2014

Modified by: @dyemanov

assignee: Dmitry Yemanov [ dimitr ]

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Feb 20, 2014

Modified by: @dyemanov

status: Open [ 1 ] => Resolved [ 5 ]

resolution: Fixed [ 1 ]

Fix Version: 3.0 Beta 1 [ 10332 ]

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Feb 20, 2014

Commented by: @helebor

Seems an ambiguous description, Dmitry. Do you mean
a) backups MADE on pre-v3 server versions can't be restored by gbak v.3 (under v.3 server) -- OOPS!
or
b) backups made by v.3 gbak can't be restored by v.3 gbak (attaching to older versions of the server) -- no surprise?

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Feb 20, 2014

Commented by: @dyemanov

The latter, in fact it's about backups made by whatever GBAK version being restored using v3 GBAK connected to the v2.5 server. It did work and generally it should work (with some exceptions like v2.5 -> pre-v2.5 due to different security class naming rules). I know we never officially promised that to work, but the code to handle that was there for years.

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Jun 3, 2015

Modified by: @pavel-zotov

status: Resolved [ 5 ] => Resolved [ 5 ]

QA Status: Cannot be tested

Test Details: Deferred. Seems test must know where GBAK v3 lives (its FB3 home folder) and must have the port number of FB 2.5 instance.
Currently I have no info how it can be done using fbt_run.

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Sep 22, 2015

Modified by: @pcisar

status: Resolved [ 5 ] => Closed [ 6 ]

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment