Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Installer script fails in some linux environments [CORE4842] #5138

Closed
firebird-issue-importer opened this issue Jun 15, 2015 · 6 comments
Closed

Comments

@firebird-issue-importer

Submitted by: Mykhaylo Masyk (miwa)

In the minimum installed Debian GNU/Linux there is no directory /usr/lib/systemd/system and installer fails during execution function installSystemdCtrlFiles from the scripts/postinstall.sh. I suppose, it will fail in any other environment with systemd and without that particular directory. This can be improved by changing the first line of mentioned function into something like

if systemdPresent && `mkdir -p $SYSTEMD_DIR`

Installer also will fail on a systems without installed libtommath package. This is more tricky, of course. However I suppose, it might be possible to write a function checkForRequiredPackages using something similar to commented checkForRPMInstall in the end of the scripts/preinstall.sh. Combining it with that "very beautiful but unused"(c)AP 2005 :) detectDistro, we can write something like that:

checkForRequiredPackages()
{
if [ detectDistro == 'Debian' ]
then
checkForDebInstall libtommath0
elif [ detectDistro == 'RH' ]
checkForRPMInstall libtommath
then
elif [ detectDistro == 'SuSE' ]
then
checkForYastInstall libtommath
fi
}

In the case maintainer will find this approach usefulness at least some kind of warning about this non-standard (because it does not installed in the typical linux environment) package would be helpful.

Commits: 100d7f5 FirebirdSQL/fbt-repository@720a613

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Jun 15, 2015

Modified by: @AlexPeshkoff

assignee: Alexander Peshkov [ alexpeshkoff ]

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Dec 25, 2015

Commented by: @AlexPeshkoff

Debian GNU/Linux there is using /lib/systemd/system instead missing on it /usr/lib/systemd/system.
/lib/systemd/system support is already present in firebird
If none of this 2 directories is present it should better be treated as broken systemd install

What about libtommath - check is added.

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Dec 25, 2015

Modified by: @AlexPeshkoff

status: Open [ 1 ] => Resolved [ 5 ]

resolution: Fixed [ 1 ]

Fix Version: 3.0 RC2 [ 10048 ]

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Dec 25, 2015

Modified by: @pavel-zotov

status: Resolved [ 5 ] => Resolved [ 5 ]

QA Status: No test => Cannot be tested

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Dec 25, 2015

Modified by: @pavel-zotov

status: Resolved [ 5 ] => Closed [ 6 ]

@firebird-issue-importer
Copy link
Author

firebird-issue-importer commented Jan 24, 2016

Modified by: @dyemanov

issuetype: Improvement [ 4 ] => Bug [ 1 ]

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

2 participants