Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot install on CentOS 8 because version of LibTomMath and LibNCurses library [CORE6170] #6418

Closed
firebird-issue-importer opened this issue Oct 24, 2019 · 9 comments

Comments

@firebird-issue-importer

Submitted by: John Franck (bozzy)

Votes: 1

If I try to install FB 3.0.4 I got the next message:

"/opt/firebird/bin/gsec: error while loading shared libraries: libtommath.so.0: cannot open shared object file: No such file or directory

As for CORE5445 , after creating a symlink named libtommath.so.0 pointing to libtommath.so.1.0.0 this problem was solved, but the next try I got:

"/opt/firebird/bin/gsec: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

I searched and in /usr/lib64 there is a libncurses.so.6, so I created another symlink named libncurses.so.5 that points to libncurses.so.6, this solved the problem.

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Oct 24, 2019

Modified by: John Franck (bozzy)

Version: 3.0.4 [ 10863 ]

description: If try to install the actual snapshot got the next message:

"Please install required library 'libtommath' before firebird, after it repeat firebird install"

After installed libtommath1 package and try again got this:

"/opt/firebird/bin/gsec: error while loading shared libraries: libtommath.so.0: cannot open shared object file: No such file or directory
Fatal error running 'systemctl --quiet start firebird-superserver.service' - exiting"

The /usr/lib/x86_64-linux-gnu directory contain a libtommath.so.1.0.0
file and a libtommath.so.1 symlink (to libtommath.so.1.0.0) . After
create a symlink with name libtommath.so.0 to libtommath.so.1.0.0 can
install the snapshot build successfully.

=>

If I try to install FB 3.0.4 I got the next message:

"/opt/firebird/bin/gsec: error while loading shared libraries: libtommath.so.0: cannot open shared object file: No such file or directory

As for CORE5445 , after creating a symlink named libtommath.so.0 pointing to libtommath.so.1.0.0 this problem was solved, but the next try I got:

"/opt/firebird/bin/gsec: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

I searched and in /usr/lib64 there is a libncurses.so.6, so I created another symlink named libncurses.so.5 that points to libncurses.so.6, this solved the problem.

environment: Debian Stretch/Testing 64bit => CentOS 8 64bit

Version: 3.0.2 [ 10785 ] =>

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Oct 24, 2019

Commented by: John Franck (bozzy)

Sorry, I created this issue by cloning CORE5445 for simplicity, I didn't know this would also clone Fix Version and Assignee (maybe this should'n occur, IMHO), anyway please correct these fields or let me know if I have to file a new issue (and delete this one).

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Oct 24, 2019

Modified by: John Franck (bozzy)

description: If I try to install FB 3.0.4 I got the next message:

"/opt/firebird/bin/gsec: error while loading shared libraries: libtommath.so.0: cannot open shared object file: No such file or directory

As for CORE5445 , after creating a symlink named libtommath.so.0 pointing to libtommath.so.1.0.0 this problem was solved, but the next try I got:

"/opt/firebird/bin/gsec: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

I searched and in /usr/lib64 there is a libncurses.so.6, so I created another symlink named libncurses.so.5 that points to libncurses.so.6, this solved the problem.

=>

If I try to install FB 3.0.4 I got the next message:

"/opt/firebird/bin/gsec: error while loading shared libraries: libtommath.so.0: cannot open shared object file: No such file or directory

As for CORE5445 , after creating a symlink named libtommath.so.0 pointing to libtommath.so.1.0.0 this problem was solved, but the next try I got:

"/opt/firebird/bin/gsec: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

I searched and in /usr/lib64 there is a libncurses.so.6, so I created another symlink named libncurses.so.5 that points to libncurses.so.6, this solved the problem.

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Apr 1, 2020

Commented by: @AlexPeshkoff

I'm not going to change ncurses version in prebuilt binaries for FB3 - that violates our rules of minor upgrades (binary should install on a system which already ran major FB version without any issues). FB4 starting with beta2 will be built using ncurses6.

What about your issue - I doubt symlink is best solution here, better use backward compatibility package
https://centos.pkgs.org/8/centos-baseos-x86_64/ncurses-compat-libs-6.1-7.20180224.el8.x86_64.rpm.html
prebuilt package for centos8 or build from sources yourself.

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Apr 1, 2020

Modified by: @AlexPeshkoff

status: Open [ 1 ] => Resolved [ 5 ]

resolution: Fixed [ 1 ]

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Apr 2, 2020

Commented by: John Franck (bozzy)

Ok for fixing in FB4 beta 2.

Also thank you for pointing me to install ncurses5 backward compatibility package on CentOS 8. Anyway I'm running FB3.0.4 successfully on a quite busy test machine running CentOS 8 and ncurses6 with the symlink for months now, just to let you know.

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Apr 2, 2020

Commented by: @AlexPeshkoff

That's funny - in theory major version upgrade should mean incompatible API/ABI changes. Are you running on linux server-only or also use utilities, particular isql?

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Apr 2, 2020

Commented by: John Franck (bozzy)

I've also used isql, although not so much, and also gbak and nbackup.

@firebird-issue-importer
Copy link
Author

@firebird-issue-importer firebird-issue-importer commented Apr 3, 2020

Commented by: @AlexPeshkoff

I asked about isql cause this is the only place where we use readline for fancy command-line editing which in turn uses ncurses. The fact that it works can mean that we use very narrow part of ncurses or.. major part of soname was upgraded without good reasons to do it.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants