Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update dependencies #82

Merged
merged 14 commits into from Apr 2, 2021
Merged

Update dependencies #82

merged 14 commits into from Apr 2, 2021

Conversation

Flix6x
Copy link
Contributor

@Flix6x Flix6x commented Apr 2, 2021

This includes a new major release of flask-security-too(closes #24). At first glance I think we're good, but maybe you can take a better look at their release notes, too?

@Flix6x Flix6x added the security label Apr 2, 2021
@Flix6x Flix6x requested a review from nhoening Apr 2, 2021
@Flix6x Flix6x self-assigned this Apr 2, 2021
@nhoening
Copy link
Contributor

@nhoening nhoening commented Apr 2, 2021

I'd make the dependency on >= 4.0 explicit, as it's non-backward compatible. I added a link to issue #24 where they provide a list of concerning topics, e.g. emailing.

There is no need to do this in version 0.2.4 right?

I'd say an issue like this is perfect to handle right after a release.

@Flix6x
Copy link
Contributor Author

@Flix6x Flix6x commented Apr 2, 2021

Good suggestion to merge this immediately after release. And I added the minimum requirement just now.

@nhoening
Copy link
Contributor

@nhoening nhoening commented Apr 2, 2021

I think you meant to use >= 4.0 and not <= 4.0?

@Flix6x
Copy link
Contributor Author

@Flix6x Flix6x commented Apr 2, 2021

Good catch.

@nhoening
Copy link
Contributor

@nhoening nhoening commented Apr 2, 2021

With the fix to RowProxy (nice work, I noticed this problem before), I believe we are depending on a new version of sqlalchemy >= 1.4, or am I incorrect? If so, I believe that, too, would need to be explicit (we are not backwards-compatible).

@Flix6x Flix6x merged commit 717466b into main Apr 2, 2021
2 checks passed
@Flix6x Flix6x deleted the update-dependencies branch Apr 2, 2021
@nhoening nhoening added this to the 0.4.0 milestone Apr 16, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

Successfully merging this pull request may close these issues.

2 participants