New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support 0.14.0-beta1 #104

Closed
wants to merge 1 commit into
base: master
from

Conversation

Projects
None yet
4 participants
@slorber

slorber commented Jul 3, 2015

I think this is required to use the new beta version.
See also gaearon/react-hot-api#18

@mjohnston

This comment has been minimized.

mjohnston commented Aug 24, 2015

We should probably make this "0.14-beta-* and up".

@slorber

This comment has been minimized.

slorber commented Aug 25, 2015

@mjohnston yes

Take a look here:
facebook/react#4542

You can use something like:

"peerDependencies": {
    "react": "^0.13.0 || ^0.14.0-alpha"
  },
@gre

This comment has been minimized.

Contributor

gre commented Oct 8, 2015

sounds like we can make a range that accepts 0.14.0 now that it is released ;)

    "react": ">=0.13.0 <0.15.0"
@gre

This comment has been minimized.

Contributor

gre commented Oct 8, 2015

also I don't think this PR is complete. Ideally we should also fix some warnings (a lot of Warning: ReactDOMComponent: Do not access .getDOMNode() of a DOM node; instead, use the node directly.)

@mjohnston

This comment has been minimized.

mjohnston commented Oct 8, 2015

@gre Agreed, we should make the necessary changes to move onto 0.14.

@gre

This comment has been minimized.

Contributor

gre commented Oct 22, 2015

i've provided another PR #115

@tuxracer tuxracer closed this Jan 7, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment