Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Foodcritic Installation Fails in Ubuntu 12.10 #83

Closed
DracoAter opened this Issue Oct 27, 2012 · 6 comments

Comments

Projects
None yet
4 participants

and in any Debian-based system that uses -Werror=format-security
http://stackoverflow.com/questions/13085404/installing-nokogiri-v-1-5-0-gem-in-ubuntu-12-10

Suppose to update dependencies to nokogiri~>1.5.4

twirrim commented Nov 13, 2012

This is making it difficult to get foodcritic and/or test-kitchen working on Ubuntu 12.10 machines, any chance this could be fixed?

Owner

acrmp commented Nov 13, 2012

Thanks guys!
Related Nokogiri issue: sparklemotion/nokogiri#680

xml_xpath_context.c: In function ‘xpath_generic_exception_handler’:
xml_xpath_context.c:184:3: error: format not a string literal and no format arguments [-Werror=format-security]
cc1: some warnings being treated as errors
make: *** [xml_xpath_context.o] Error 1

I think that got sorted out and fixed in 1.5.5 can you give it a try?

twirrim commented Nov 22, 2012

That did the trick, thanks!

twirrim commented Dec 23, 2012

Any chance you could update the gem on rubygems? It's an outdated version that still calls the old nokogiri and it's making installing software difficult :(

Owner

acrmp commented Dec 27, 2012

@twirrim Done - released as 1.7.0.

@acrmp acrmp closed this Feb 24, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment