Permalink
Browse files

Updated dependencies (#305)

  • Loading branch information...
joachimmetz committed Feb 2, 2019
1 parent 8a9d847 commit 9201c67f93d6017a9dd60f3715232203aac20ec5
Showing with 30 additions and 12 deletions.
  1. +1 −1 artifacts/__init__.py
  2. +2 −2 config/dpkg/changelog
  3. +1 −1 config/dpkg/control
  4. +2 −0 config/travis/install.sh
  5. +1 −1 setup.cfg
  6. +23 −7 setup.py
@@ -1,4 +1,4 @@
# -*- coding: utf-8 -*-
"""ForensicArtifacts.com Artifact Repository."""

__version__ = '20190113'
__version__ = '20190129'
@@ -1,5 +1,5 @@
artifacts (20190113-1) unstable; urgency=low
artifacts (20190129-1) unstable; urgency=low

* Auto-generated

-- Forensic artifacts <forensicartifacts@googlegroups.com> Sun, 13 Jan 2019 09:44:56 +0100
-- Forensic artifacts <forensicartifacts@googlegroups.com> Tue, 29 Jan 2019 07:18:25 +0100
@@ -31,7 +31,7 @@ Description: Python 3 module of ForensicArtifacts.com Artifact Repository

Package: artifacts-tools
Architecture: all
Depends: python-artifacts, python (>= 2.7~), ${python:Depends}, ${misc:Depends}
Depends: python-artifacts, ${python:Depends}, ${misc:Depends}
Description: Tools of ForensicArtifacts.com Artifact Repository
A free, community-sourced, machine-readable knowledge base of forensic
artifacts that the world can use both as an information source and within other tools.
@@ -51,6 +51,8 @@ then
if test ${TRAVIS_PYTHON_VERSION} = "2.7";
then
sudo add-apt-repository ppa:gift/pylint2 -y;
else
sudo add-apt-repository ppa:gift/pylint3 -y;
fi
fi

@@ -8,7 +8,7 @@ doc_files = ACKNOWLEDGEMENTS
AUTHORS
LICENSE
README
build_requires = python-setuptools
build_requires = python2-setuptools
requires = python2-pyyaml >= 3.10

[bdist_wheel]
@@ -93,7 +93,7 @@ def _make_spec_file(self):
python_spec_file = []
for line in iter(spec_file):
if line.startswith('Summary: '):
summary = line
summary = line[9:]

elif line.startswith('BuildRequires: '):
line = 'BuildRequires: {0:s}-setuptools, {0:s}-devel'.format(
@@ -104,6 +104,7 @@ def _make_spec_file(self):
if python_package == 'python3':
requires = requires.replace('python-', 'python3-')
requires = requires.replace('python2-', 'python3-')
continue

elif line.startswith('%description'):
in_description = True
@@ -121,6 +122,15 @@ def _make_spec_file(self):
line = '%py2_install'

elif line.startswith('%files'):
python_spec_file.extend([
'%package -n %{name}-tools',
'Requires: python-artifacts',
'Summary: Tools for {0:s}'.format(summary),
'',
'%description -n %{name}-tools'])

python_spec_file.extend(description)

lines = [
'%files -n %{name}-data',
'%defattr(644,root,root,755)',
@@ -139,8 +149,7 @@ def _make_spec_file(self):
'%{python3_sitelib}/artifacts*.egg-info/*',
'',
'%exclude %{_prefix}/share/doc/*',
'%exclude %{python3_sitelib}/artifacts/__pycache__/*',
'%exclude %{_bindir}/*.py'])
'%exclude %{python3_sitelib}/artifacts/__pycache__/*'])

else:
lines.extend([
@@ -149,8 +158,7 @@ def _make_spec_file(self):
'',
'%exclude %{_prefix}/share/doc/*',
'%exclude %{python2_sitelib}/artifacts/*.pyc',
'%exclude %{python2_sitelib}/artifacts/*.pyo',
'%exclude %{_bindir}/*.py'])
'%exclude %{python2_sitelib}/artifacts/*.pyo'])

python_spec_file.extend(lines)
break
@@ -172,10 +180,13 @@ def _make_spec_file(self):
python_spec_file.extend([
'Obsoletes: python-artifacts < %{version}',
'Provides: python-artifacts = %{version}'])
python_summary = 'Python 2 module of {0:s}'.format(summary)
else:
python_summary = 'Python 3 module of {0:s}'.format(summary)

python_spec_file.extend([
'Requires: %{{name}}-data, {0:s}'.format(requires),
'{0:s}'.format(summary),
'Requires: artifacts-data {0:s}'.format(requires),
'Summary: {0:s}'.format(python_summary),
'',
'%description -n {0:s}-%{{name}}'.format(python_package)])

@@ -190,6 +201,11 @@ def _make_spec_file(self):

python_spec_file.append(line)

python_spec_file.extend([
'',
'%files -n %{name}-tools',
'%{_bindir}/*.py'])

return python_spec_file


0 comments on commit 9201c67

Please sign in to comment.