Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Ctrl+Alt+O keyboard shortcut conflict #23

Closed
wjurij opened this issue Oct 31, 2018 · 8 comments

Comments

@wjurij
Copy link

commented Oct 31, 2018

Since version 1.22 there is a shortcut Ctrl+Alt+O assigned to "Open in file explorer", which conflicts with shortcut for a polish letter "ó", which makes it inconvenient to write commit messages in polish.

@DanPristupov

This comment has been minimized.

Copy link
Contributor

commented Nov 1, 2018

Thank you for reporting the issue.

How is that case handled in other applications?

For example:

  • Ctrl+Alt+O is "Show Output" shortcut in Visual studio
  • Ctrl+Alt+O is "Outline View" in MS Word

It seems that Fork should not handle that shortcut when Commit message field is active. Do you think that will solve the problem?

@DanPristupov DanPristupov changed the title Keyboard shortcut conflict Ctrl+Alt+O keyboard shortcut conflict Nov 1, 2018

@wjurij

This comment has been minimized.

Copy link
Author

commented Nov 2, 2018

Quite interesting, because it seems that despite being assigned, this shortcut just doesnt work neither in VS nor in Word and just inserts the letter.

As far as I remember, there was a similar problem in some graphic card driver software, but it had configurable shortcuts, so it was solveable for the end-user.

@DanPristupov DanPristupov added this to the 1.30 milestone Mar 20, 2019

@DanPristupov

This comment has been minimized.

Copy link
Contributor

commented Mar 22, 2019

In 1.30 I updated the shortcuts to not be fired on AltGr+O

@DanPristupov

This comment has been minimized.

Copy link
Contributor

commented Mar 23, 2019

I got the following feedback:

The explorator doesn't open anymore, but looks like typing this character is still blocked. I think you suppress the original event and it still is redirected but now to nowhere.

I'll fix this in the next update.

@DanPristupov DanPristupov modified the milestones: 1.30, 1.31 Mar 23, 2019

@wjurij

This comment has been minimized.

Copy link
Author

commented Mar 25, 2019

Thank you very much for addressing the issue.

@DanPristupov

This comment has been minimized.

Copy link
Contributor

commented Apr 5, 2019

1.31 is out. Please try it.

@wjurij

This comment has been minimized.

Copy link
Author

commented Apr 8, 2019

Now it is working very well. Thank you for resolving this.

@wjurij wjurij closed this Apr 8, 2019

@DanPristupov

This comment has been minimized.

Copy link
Contributor

commented Apr 8, 2019

Finally!

Thank you for your patience :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.