Fix Breaking Build #89

Merged
merged 2 commits into from May 7, 2016

Projects

None yet

4 participants

@ltegman
Member
ltegman commented May 2, 2016

Fixes issue with missing config.json breaking travis as well as updating our lint config, fixing lint issues, and fixing a broken test.

@BerkeleyTrue BerkeleyTrue added the QA label May 2, 2016
@abhisekp abhisekp commented on the diff May 2, 2016
test/Bonfires.spec.js
@@ -91,14 +91,14 @@ test('Bonfires test', t => {
st.end();
});
- t.test('should find raw wiki hints from KBase', st =>{
+ t.test('should find raw wiki hints from KBase', st => {
st.plan(1);
@abhisekp
abhisekp May 2, 2016 edited Member

remove all plans
just end is fine and better. 👍

@ltegman
ltegman May 2, 2016 Member

That is not within the scope of this change and not needed.

@abhisekp
Member
abhisekp commented May 2, 2016 edited

@ltegman i get an "caught" error while using about command.

Testing in https://gitter.im/GitterBotX/playground

@ltegman
Member
ltegman commented May 2, 2016

Could you post the full error you're seeing?

@abhisekp
Member
abhisekp commented May 2, 2016

@ltegman

GBot>  in| about @abhisekp 
    at IncomingMessage.response.on.err (/media/Xtras/GitRepos/camperbot/lib/utils/HttpWrap.js:40:17)
    at emitNone (events.js:91:20)
    at IncomingMessage.emit (events.js:185:7)
    at endReadableNT (_stream_readable.js:926:12)
    at _combinedTickCallback (internal/process/next_tick.js:74:11)
    at process._tickDomainCallback (internal/process/next_tick.js:122:9)
    at IncomingMessage.response.on.err (/media/Xtras/GitRepos/camperbot/lib/utils/HttpWrap.js:41:17)
    at emitNone (events.js:91:20)
    at IncomingMessage.emit (events.js:185:7)
    at endReadableNT (_stream_readable.js:926:12)
    at _combinedTickCallback (internal/process/next_tick.js:74:11)
    at process._tickDomainCallback (internal/process/next_tick.js:122:9)
    at thanksCommands.showInfoCallback (/media/Xtras/GitRepos/camperbot/lib/bot/cmds/thanks.js:114:13)
    at IncomingMessage.response.on.err (/media/Xtras/GitRepos/camperbot/lib/utils/HttpWrap.js:44:9)
    at emitNone (events.js:91:20)
    at IncomingMessage.emit (events.js:185:7)
    at endReadableNT (_stream_readable.js:926:12)
    at _combinedTickCallback (internal/process/next_tick.js:74:11)
    at process._tickDomainCallback (internal/process/next_tick.js:122:9)

@ltegman
Member
ltegman commented May 3, 2016

@abhisekp I looked into this and I think it's just an issue with the apiServer value in the example config being missing the leading www. I've added a commit to fix this. Let me know if making that change in your config fixes the issue for you.

@abhisekp
Member
abhisekp commented May 3, 2016

@ltegman yep! That fixed it. 👍

@raisedadead raisedadead merged commit 55bda79 into freeCodeCamp:master May 7, 2016

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
@BerkeleyTrue BerkeleyTrue removed the QA label May 7, 2016
@raisedadead
Member

Thanks for the PR @ltegman I cant seem to invoke the bot, messed up my config somehow. @abhisekp has tested it locally.

I went through the changes and they look solid to me.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment