3.0.x - no response from proxy server - request does not go through "Post-Proxy-Type Fail" #576

Closed
nchaigne opened this Issue Apr 2, 2014 · 2 comments

Projects

None yet

3 participants

@nchaigne
Contributor
nchaigne commented Apr 2, 2014

Case of an Access-Request proxied to a home server which does not respond.

The request goes through:

  • authorize
  • pre-proxy
    (no response from proxy server)
  • Post-Auth-Type REJECT

It should go through "Post-Proxy-Type Fail".
But it doesn't.

@alandekok
Member

Please post the debug output. That will help to track it down.

@nchaigne
Contributor
nchaigne commented Apr 3, 2014

Here is the debug output:

rad_recv: Access-Request packet from host 10.67.106.9 port 54222, id=248, length=105
        Chargeable-User-Identity = ''
        NAS-IP-Address = 10.20.0.0
        NAS-Identifier = 'LiveBox1'
        Calling-Station-Id = '00:14:5E:17:38:EC'
        User-Name = 'test-cuix2@SIM.orange.fr'
        EAP-Message = 0x78
        Message-Authenticator = 0x49cc1373ccdda6a760c9d27315c494d1
(0) # Executing section authorize from file /opt/application/mwpsrs/current/etc/raddb/sites-enabled/server-test-proxy
(0)   authorize {
(0)   update control {
(0)     Proxy-To-Realm := '3gpp.orange.fr'
(0)   } # update control = noop
(0)  } #  authorize = noop
(0) Proxying request to home server 10.67.141.74 port 11819
Sending Access-Request of id 5 from 0.0.0.0 port 51723 to 10.67.141.74 port 11819
        Chargeable-User-Identity = ''
        NAS-IP-Address = 10.20.0.0
        NAS-Identifier = 'LiveBox1'
        Calling-Station-Id = '00:14:5E:17:38:EC'
        User-Name = 'test-cuix2@SIM.orange.fr'
        EAP-Message = 0x78
        Message-Authenticator = 0x49cc1373ccdda6a760c9d27315c494d1
        Proxy-State = 0x323438
Waking up in 0.3 seconds.
Waking up in 0.4 seconds.
(0) Expecting proxy response no later than 10 seconds from now
Waking up in 9.1 seconds.
(0) No proxy response, giving up on request and marking it done
Marking home server 10.67.141.74 port 11819 as zombie (it has not responded in 10 seconds).
(0) ERROR: Failing request - proxy ID 5, due to lack of any response from home server 10.67.141.74 port 11819
(0) There was no response configured: rejecting request
(0) Using Post-Auth-Type Reject
(0) # Executing group from file /opt/application/mwpsrs/current/etc/raddb/sites-enabled/server-test-proxy
(0)  Post-Auth-Type REJECT {
(0)    if (!Proxy-To-Realm)
(0)    if (!Proxy-To-Realm)  -> TRUE
(0)   if (!Proxy-To-Realm)  { ... } # empty sub-section is ignored
(0)  } # Post-Auth-Type REJECT = noop
Sending Access-Reject of id 248 from 10.67.106.9 port 1812 to 10.67.106.9 port 54222
(0) Finished request 0.
@alandekok alandekok closed this in eccf3e8 Apr 11, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment