Skip to content

SSL_read: I/O error (Windows 7) #729

Open
livelace opened this Issue Sep 19, 2012 · 12 comments
@livelace

freerdp branch:

  1. master
  2. 1.0-stable

software:

  1. Gentoo x64
  2. openssl 0.9.8x/1.0.0j

WORK for Windows 2008 R2 (full patched):

xfreerdp -u user -p password --app --plugin channels/rail/rail.so --data "%SYSTEMDRIVE%\Windows\system32\notepad.exe" -- 192.168.110.2

FAIL for Windows 7 Professional x64 (1.0-stable brach, full patched):

xfreerdp -u user -p password --app --plugin channels/rail/rail.so --data "%SYSTEMDRIVE%\Windows\system32\notepad.exe" -- 192.168.116.38

loading plugin channels/rail/rail.so
connected to 192.168.116.38:3389
pduType bad
SSL_read: I/O error

FAIL for Windows 7 Professional x64 (master brach, full patched):

xfreerdp -u user -p password --app --plugin channels/rail/rail.so --data "%SYSTEMDRIVE%\Windows\system32\notepad.exe" -- 192.168.116.38

loading plugin channels/rail/rail.so
connected to 192.168.116.38:3389
Unable to detect time zone
expected PDU_TYPE_DEMAND_ACTIVE 0001, got 0007
rdp_client_connect_demand_active failed

PS. User logged out.

UP. Additional debug:

expected PDU_TYPE_DEMAND_ACTIVE 0001, got 0007
DBG_RDP rdp_recv_data_pdu (507): recv Save Session Info Data PDU (0x26), length:610
Local < Remote
0000 03 00 00 09 02 f0 80 21 80 .......!.
rdp_client_connect_demand_active failed

@Mazwak
Mazwak commented Feb 6, 2013

I have the same problem. After some research, I found it does not work on seven pro. You need enterprise or ultimate.

http://blogs.msdn.com/b/rds/archive/2009/12/15/remoteapp-for-hyper-v.aspx

@olavgun
olavgun commented Feb 12, 2013

xfreerdp /d:domain /u:myuser /p:mypassw /v:windows2012server with Terminal Services installed
connected to :3389
Unable to get current timezone rule
expected PDU_TYPE_DEMAND_ACTIVE 0001, got 0007
rdp_client_connect_demand_active failed

xfreerdp --version
This is FreeRDP version 1.1.0-dev (git 1.0.1-1912-g855d)

remote is windows server 2012 with Terminal Services installed

@yoshi314

@olavgun - i kept hitting this error on a similar server when user got remote access disabled for some reason.

It required a permission fix on server side. Rdesktop would get me to login screen, but server would display a prompt that i am not authorized to open a session after entering the password.

@bmiklautz
FreeRDP member

This should work with current master/stable-1.1 - can anyone verify this?

@dehart
dehart commented Jan 15, 2014

Tested this with stable-1.1 branch on Windows 7 pro:
xfreerdp /u:Michael /p:awerawer /d:WORKSPACE /app:"||calc" /v:WINPC

expected PDU_TYPE_DEMAND_ACTIVE 0001, got 0007
SSL_read: I/O error: Connection reset by peer (104)
This is FreeRDP version 1.1.0-beta1 (git 1.1.0-beta+2013071101-123-g997d)

@freechelmi

We have the same problem here with 1.0.2 ( normal ..) :
connected to 192.168.2.51:3389
pduType bad SSL_read: I/O error

Connection with remmina in Full screen is OK though which I fail to undertand.

Will try the master branch

@hardening

And does it work with master ?

@lkraav
lkraav commented Jun 21, 2015

net-misc/freerdp-1.2.1_pre20150326

I'm attempting this against Windows 10 TP 10130, so that oculd also be a reason it's not working. RemoteApp Tool doesn't mention Windows 10 at all for now.

$ [-] xfreerdp /app:"||Skype" /v:ten
[00:29:39:895] [13834:13835] [INFO][com.freerdp.client.common.cmdline] - loading channel rail
[00:29:39:896] [13834:13835] [INFO][com.freerdp.client.x11] - No user name set. - Using login name: leho
Password: 
[00:29:42:136] [13834:13835] [ERROR][com.freerdp.core.capabilities] - expected PDU_TYPE_DEMAND_ACTIVE 0001, got 0007
[00:29:42:152] [13834:13835] [ERROR][com.freerdp.core] - ERRINFO_LOGOFF_BY_USER (0x0000000C):The disconnection was initiated by the user logging off his or her session on the server.
[00:29:42:152] [13834:13835] [ERROR][com.freerdp.core.rdp] - DisconnectProviderUltimatum: reason: 3
[00:29:47:143] [13834:13835] [ERROR][com.freerdp.client.x11] - Authentication only, exit status 1

Regular connections work fine, but RemoteApp would sure be nice.

@hardening

@lkraav I think this bug is fixed on master, you should give a try

@lkraav
lkraav commented Jun 22, 2015

Still fails :/

$ [-] xfreerdp /pub/Downloads/Skype.rdp /v:ten
[19:46:22:368] [26254:26255] [INFO][com.freerdp.client.common.cmdline] - loading channel rdpdr
[19:46:22:368] [26254:26255] [INFO][com.freerdp.client.common.cmdline] - loading channel rdpsnd
[19:46:22:368] [26254:26255] [INFO][com.freerdp.client.common.cmdline] - loading channel rail
[19:46:22:368] [26254:26255] [INFO][com.freerdp.client.x11] - No user name set. - Using login name: leho
[19:46:22:695] [26254:26255] [INFO][com.freerdp.client.x11] - Certificate details:
[19:46:22:695] [26254:26255] [INFO][com.freerdp.client.x11] -   Subject: CN = ten
[19:46:22:695] [26254:26255] [INFO][com.freerdp.client.x11] -   Issuer: CN = ten
[19:46:22:695] [26254:26255] [INFO][com.freerdp.client.x11] -   Thumbprint: cd:74:63:10:9f:96:72:86:e2:29:b4:b0:0e:cd:f4:d9:a1:e4:91:58
[19:46:22:695] [26254:26255] [INFO][com.freerdp.client.x11] - The above X.509 certificate could not be verified, possibly because you do not have the CA certificate in your certificate store, or the certificate has expired. Please look at the documentation on how to create local certificate store for a private CA.
[19:46:22:695] [26254:26255] [INFO][com.freerdp.client.x11] - Do you trust the above certificate? (Y/N) 
Y
Password: 
[19:46:31:629] [26254:26255] [ERROR][com.freerdp.core.capabilities] - expected PDU_TYPE_DEMAND_ACTIVE 0001, got 0007
[19:46:31:644] [26254:26255] [ERROR][com.freerdp.core] - ERRINFO_LOGOFF_BY_USER (0x0000000C):The disconnection was initiated by the user logging off his or her session on the server.
[19:46:31:644] [26254:26255] [ERROR][com.freerdp.core.rdp] - DisconnectProviderUltimatum: reason: 3
[19:46:36:656] [26254:26255] [ERROR][com.freerdp.client.x11] - Authentication only, exit status 1
leho@papaya ~ $ [-] xfreerdp /version
This is FreeRDP version 1.2.4-dev (git c8731ea)
@MurzNN
MurzNN commented Jul 7, 2015

Got the same error when try to use RemoteApp:

$ xfreerdp -u User -p Pass --app --plugin /usr/lib/x86_64-linux-gnu/freerdp/rail.so --data "c:\notepad.exe" -- 192.168.1.128
loading plugin /usr/lib/x86_64-linux-gnu/freerdp/rail.so
connected to 192.168.1.128:3389
pduType bad
SSL_read: I/O error

When I try connect without "--app" argument - all connects normally.

@YoussF
YoussF commented Jul 28, 2015

Got the same error when try to use RemoteApp @MurzNN

Same for me. Remote is a Windows 8.1

@bmiklautz bmiklautz removed this from the 1.1 milestone May 25, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.