No RDP connection after latest update Ubuntu #657

Closed
kmg454 opened this Issue Oct 21, 2015 · 9 comments

Projects

None yet

5 participants

@kmg454
kmg454 commented Oct 21, 2015

Since 20-10-2015 after a update of Ubuntu we can't make an RDP connection anymore

@antenore
Member

Hi @kmg454
can you be more specific please? What version of remmina and ubuntu do you have?
Did you install it from the PPA?

@kmg454
kmg454 commented Oct 22, 2015

Hi.

I'm using the latest release of Ubuntu 14.04 LTS and Remmina 0.9.99.1

My RDP connection was working for 2 years without a problem but after
the latest system update of Ubuntu 20-10-2015 it will not connect anymore.

When I use an other RDP client it works for 100%.

Met vriendelijke groet,
Johan Velthuizen
Velthuizen Webdesign & Media
Christineweg 17
2961 AB Kinderdijk
Tel. 078 6990167
www.velthuizen.nl

Op 21-10-15 om 21:27 schreef Antenore Gatta:

Hi @kmg454 https://github.com/kmg454
can you be more specific please? What version of remmina and ubuntu do
you have?
Did you install it from the PPA?


Reply to this email directly or view it on GitHub
#657 (comment).

@antenore
Member

This version is not supported anymore by us as it's too old, you should open a bug to Ubuntu (please do, it's important).

In the meanwhile you can use our ppa

sudo apt-add-repository ppa:remmina-ppa-team/remmina-next
sudo apt-get update
sudo apt-get install remmina remmina-plugin-rdp libfreerdp-plugins-standard

You will have also several new features and much less bugs.

Remove completely the old remmina and follow our wiki.

https://github.com/FreeRDP/Remmina/wiki

In case of issues let me know.

@faune
faune commented Oct 26, 2015

I've used remmina with remmina-plugin-rdp previously on Ubuntu 14.04.03LTS, but I beleive recent updates in this project have introduced a regression:

$ sudo apt-get install remmina-plugin-rdp
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libfreerdp-plugins-standard libfreerdp1
The following NEW packages will be installed:
  libfreerdp1 remmina-plugin-rdp
The following packages will be upgraded:
  libfreerdp-plugins-standard
1 upgraded, 2 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/881 kB of archives.
After this operation, 2 963 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
Selecting previously unselected package libfreerdp1:amd64.
(Reading database ... 289918 files and directories currently installed.)
Preparing to unpack .../libfreerdp1_1.2.0~git20150207+dfsg-0trusty2_amd64.deb ...
Unpacking libfreerdp1:amd64 (1.2.0~git20150207+dfsg-0trusty2) ...
dpkg: error processing archive /var/cache/apt/archives/libfreerdp1_1.2.0~git20150207+dfsg-0trusty2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/librdtk.so.1.1.0', which is also in package libfreerdp1.1:amd64 1.1.0~git20150628.1.084b365+dfsg-0+sipe~173~ubuntu14.04.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../libfreerdp-plugins-standard_1.2.0~git20150207+dfsg-0trusty2_amd64.deb ...
Unpacking libfreerdp-plugins-standard:amd64 (1.2.0~git20150207+dfsg-0trusty2) over (1.1.0~git20150628.1.084b365+dfsg-0+sipe~173~ubuntu14.04.1) ...
Selecting previously unselected package remmina-plugin-rdp.
Preparing to unpack .../remmina-plugin-rdp_1.1.2-ppa1+789+next+201510182216~ubuntu14.04.1_amd64.deb ...
Unpacking remmina-plugin-rdp (1.1.2-ppa1+789+next+201510182216~ubuntu14.04.1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libfreerdp1_1.2.0~git20150207+dfsg-0trusty2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I believe the conflict is due to me using the pidgin-sipe PPA, which also has its own version of libfreerdp but the package names do not match and they are attempting to overwrite each others files.

I understand that supporting all variants of unofficial PPAs can be tricky to handle by you, but can you please advice on what can be done to solve this? I'm depending on both Remmina supporting RDP and the latest improvements to Pidgin SIPE.

@kmg454
kmg454 commented Oct 26, 2015

I just installed the package by the ppa and everything works as
aspected, but when installing it removed my VLC package WHY?

Met vriendelijke groet,
Johan Velthuizen
Velthuizen Webdesign & Media
Christineweg 17
2961 AB Kinderdijk
Tel. 078 6990167
www.velthuizen.nl

Op 26-10-15 om 13:26 schreef faune:

I've used remmina with remmina-plugin-rdp previously on Ubuntu
14.04.03LTS, but I beleive recent updates in this project have
introduced a regression:

|$ sudo apt-get install remmina-plugin-rdp Reading package lists...
Done Building dependency tree Reading state information... Done The
following extra packages will be installed:
libfreerdp-plugins-standard libfreerdp1 The following NEW packages
will be installed: libfreerdp1 remmina-plugin-rdp The following
packages will be upgraded: libfreerdp-plugins-standard 1 upgraded, 2
newly installed, 0 to remove and 1 not upgraded. Need to get 0 B/881
kB of archives. After this operation, 2 963 kB of additional disk
space will be used. Do you want to continue? [Y/n] Selecting
previously unselected package libfreerdp1:amd64. (Reading database ...
289918 files and directories currently installed.) Preparing to unpack
.../libfreerdp1_1.2.0git20150207+dfsg-0trusty2_amd64.deb ...
Unpacking libfreerdp1:amd64 (1.2.0
git20150207+dfsg-0trusty2) ...
dpkg: error processing archive
/var/cache/apt/archives/libfreerdp1_1.2.0git20150207+dfsg-0trusty2_amd64.deb
(--unpack): trying to overwrite
'/usr/lib/x86_64-linux-gnu/librdtk.so.1.1.0', which is also in package
libfreerdp1.1:amd64
1.1.0
git20150628.1.084b365+dfsg-0+sipe173ubuntu14.04.1 dpkg-deb:
error: subprocess paste was killed by signal (Broken pipe) Preparing
to unpack
.../libfreerdp-plugins-standard_1.2.0git20150207+dfsg-0trusty2_amd64.deb
... Unpacking libfreerdp-plugins-standard:amd64
(1.2.0
git20150207+dfsg-0trusty2) over
(1.1.0git20150628.1.084b365+dfsg-0+sipe173ubuntu14.04.1) ...
Selecting previously unselected package remmina-plugin-rdp. Preparing
to unpack
.../remmina-plugin-rdp_1.1.2-ppa1+789+next+201510182216
ubuntu14.04.1_amd64.deb
... Unpacking remmina-plugin-rdp
(1.1.2-ppa1+789+next+201510182216ubuntu14.04.1) ... Errors were
encountered while processing:
/var/cache/apt/archives/libfreerdp1_1.2.0
git20150207+dfsg-0trusty2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1) |

I believe the conflict is due to me using the pidgin-sipe PPA, which
also has its own version of libfreerdp but the package names do not
match and they are attempting to overwrite each others files.

I understand that supporting all variants of unofficial PPAs can be
tricky to handle by you, but can you please advice on what can be done
to solve this? I'm depending on both Remmina supporting RDP and the
latest improvements to Pidgin SIPE.


Reply to this email directly or view it on GitHub
#657 (comment).

@antenore
Member

@giox069 @dktrkranz Can you please advise on these issues? Thanks!

@maMykola

After last update of remmina and ubuntu (14.04.3 LTS) rdp protocol disappeared from the list.

after executing the following commands:

apt-get remove --purge remina remina-plugin-*
apt-get install remina remina-plugin-rdp libfreerdp-plugins-standard

no rdp protocol in the list

ii  freerdp-x11                                           1.2.0~git20151218+dfsg-0trusty1 amd64                           RDP client for Windows Terminal Services
ii  remmina                                               1.1.2-ppa1+819+next+20160112183 amd64                           remote desktop client for GNOME desktop environment
ii  remmina-plugin-rdp                                    1.1.2-ppa1+819+next+20160112183 amd64                           RDP plugin for remmina remote desktop client
@maMykola

After several tries, I remove remmina and plugins. I found folder /opt/remmina_devel that has also removed. Then I install remmina and rdp appeared in the list!!!

@giox069
Contributor
giox069 commented Jan 13, 2016

Ok, thank you @maMykola. I'm closing this issue now. It's old enough to be forgotten :)

@giox069 giox069 closed this Jan 13, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment