RDP plugin fails to load #721

Closed
tmlmt opened this Issue Jan 11, 2016 · 5 comments

Projects

None yet

4 participants

@tmlmt
tmlmt commented Jan 11, 2016

Hello,
I decided to install the latest remmina version after having worked for a while with Remmina 0.9.99.1. I followed the instructions of the README file:

sudo apt-add-repository ppa:remmina-ppa-team/remmina-next
sudo apt-get update
sudo apt-get install remmina remmina-plugin-rdp libfreerdp-plugins-standard

But when I run remmina, the RDP plugin fails to load:

$ remmina

** (remmina:3098): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-BaygoocEf4: Connection refused
Failed to load plugin: /usr/lib/i386-linux-gnu/remmina/plugins/remmina-plugin-rdp.so.
Error: libfreerdp.so.1.2: cannot open shared object file: No such file or directory

Here are different outputs:

$ dpkg -l | grep remm
ii  remmina                                     1.1.2-ppa1+818+next+201601111311~ubuntu14.04.1   i386         remote desktop client for GNOME desktop environment
ii  remmina-common                              1.1.2-ppa1+818+next+201601111311~ubuntu14.04.1   all          common files for remmina remote desktop client
ii  remmina-plugin-rdp                          1.1.2-ppa1+818+next+201601111311~ubuntu14.04.1   i386         RDP plugin for remmina remote desktop client
ii  remmina-plugin-vnc                          1.1.2-ppa1+818+next+201601111311~ubuntu14.04.1   i386         VNC plugin for remmina remote desktop client

I am running Xubuntu 14.04.3 on an i686 machine.

@Njenkins93

Had no issues until upgrading this morning, I get pretty much the same error-
Failed to load plugin: /usr/lib/x86_64-linux-gnu/remmina/plugins/remmina-plugin-rdp.so.
Error: libfreerdp.so.1.2: cannot open shared object file: No such file or directory

Also missing all plugins but SSH/SFTP.
Running Mint 17.3 Rosa

@giox069
Contributor
giox069 commented Jan 11, 2016

@dktrkranz I think remmina for trusty is looking for the old freerdp1.2 instead of the new 2.0 updated today in trusty PPA. Is it possible ?

@dktrkranz
Contributor

It wasn't rebuilt against latest FreeRDP yet. I manually requested a build, version 1.1.2-ppa1+818+next+201601111841~ubuntu14.04.1 will link against 2.0

@giox069
Contributor
giox069 commented Jan 11, 2016

Thank you @dktrkranz. I just did an apt-get update and apt-get upgrade on 14.04.3 and now it works.

@Njenkins93

Affirmative, I can also attest that it is working now. Thank you very much!

@giox069 giox069 closed this Jan 11, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment