Skip to content
Permalink
Browse files

Remove PHP5 support

  • Loading branch information...
adrienlucas committed Aug 13, 2019
1 parent 3f0eaf0 commit 173cac14b61b087a5f1f47ec13863cbe629aaf5a
Showing with 10 additions and 10 deletions.
  1. +1 −4 .travis.yml
  2. +4 −1 README.rst
  3. +5 −5 composer.json
@@ -11,12 +11,9 @@ env:
- SYMFONY_PHPUNIT_DIR=$HOME/.phpunit_bridge

php:
- 7.3
- 7.2
- 7.1
- 7.0
- 5.6
- 5.5
- nightly

install:
- composer update
@@ -9,10 +9,13 @@ responses.
Requirements
------------

Goutte depends on PHP 5.5+ and Guzzle 6+.
Goutte depends on PHP 7.1+ and Guzzle 6+.

.. tip::

If you need support for PHP 5.5, use Goutte 3.x (latest `phar
<https://github.com/FriendsOfPHP/Goutte/releases/download/v3.1.0/goutte-v3.1.0.phar>`_).

If you need support for PHP 5.4 or Guzzle 4-5, use Goutte 2.x (latest `phar
<https://github.com/FriendsOfPHP/Goutte/releases/download/v2.0.4/goutte-v2.0.4.phar>`_).

@@ -12,10 +12,10 @@
}
],
"require": {
"php": ">=5.5.0",
"symfony/browser-kit": "~2.1|~3.0|~4.0",
"symfony/css-selector": "~2.1|~3.0|~4.0",
"symfony/dom-crawler": "~2.1|~3.0|~4.0",
"php": "^7.1.3",
"symfony/browser-kit": "~3.4|~4.0",
"symfony/css-selector": "~3.4|~4.0",
"symfony/dom-crawler": "~3.4|~4.0",
"guzzlehttp/guzzle": "^6.0"
},
"require-dev": {
@@ -27,7 +27,7 @@
},
"extra": {
"branch-alias": {
"dev-master": "3.2-dev"
"dev-master": "4.0-dev"
}
}
}

0 comments on commit 173cac1

Please sign in to comment.
You can’t perform that action at this time.