The docs state that you should simply install JMSSerializerBundle, but when I follow the docs on that bundle, I get the following:
composer require jms/serializer-bundle
Please provide a version constraint for the jms/serializer-bundle requirement: *
composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.
- Installation request for jms/metadata == 18.104.22.168 -> satisfiable by jms/metadata 1.3.0.
- jms/serializer-bundle 0.11.0 requires jms/serializer 0.11.* -> satisfiable by jms/serializer 0.11.0.
- Conclusion: don't install jms/serializer 0.11.0
- Conclusion: remove friendsofsymfony/rest-bundle 0.11.0
- jms/serializer-bundle 0.10 conflicts with friendsofsymfony/rest-bundle 0.11.0.
- jms/serializer-bundle 0.9.0 conflicts with friendsofsymfony/rest-bundle 0.11.0.
- Installation request for friendsofsymfony/rest-bundle == 0.11.0.0 -> satisfiable by friendsofsymfony/rest-bundle 0.11.0.
- Installation request for jms/serializer-bundle * -> satisfiable by jms/serializer-bundle 0.10, jms/serializer-bundle 0.11.0, jms/serializer-bundle 0.9.0.
Installation failed, reverting composer.json to its original content.
Just want to get this dang thing installed against Symfony 2.2
I wasn't able to install the JMSSerializerBundle by itself with Symfony 2.2 either.
I was able to get it working by removing the rest-bundle and installing it this way.
composer require jms/serializer-bundle #dev-master
composer require friendsofsymfony/rest-bundle #dev-master
Is there not a tagged version of these bundles that works with Symfony 2.2 or should I rely on dev-master for now?
you need to allow dev versions for now
This is still an outstanding issue, the installation documentation is incomplete.
no its not .. but if you have suggestions to improve feel free to send them .. I will not invest any time in this myself. so it goes