Not clear which version of JMSSerializerBundle to use. #419

Closed
breerly opened this Issue Apr 4, 2013 · 5 comments

Projects

None yet

3 participants

Contributor
breerly commented Apr 4, 2013

The docs state that you should simply install JMSSerializerBundle, but when I follow the docs on that bundle, I get the following:

composer require jms/serializer-bundle
Please provide a version constraint for the jms/serializer-bundle requirement: *
composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for jms/metadata == 1.3.0.0 -> satisfiable by jms/metadata 1.3.0.
    - jms/serializer-bundle 0.11.0 requires jms/serializer 0.11.* -> satisfiable by jms/serializer 0.11.0.
    - Conclusion: don't install jms/serializer 0.11.0
    - Conclusion: remove friendsofsymfony/rest-bundle 0.11.0
    - jms/serializer-bundle 0.10 conflicts with friendsofsymfony/rest-bundle 0.11.0.
    - jms/serializer-bundle 0.9.0 conflicts with friendsofsymfony/rest-bundle 0.11.0.
    - Installation request for friendsofsymfony/rest-bundle == 0.11.0.0 -> satisfiable by friendsofsymfony/rest-bundle 0.11.0.
    - Installation request for jms/serializer-bundle * -> satisfiable by jms/serializer-bundle 0.10, jms/serializer-bundle 0.11.0, jms/serializer-bundle 0.9.0.


Installation failed, reverting composer.json to its original content.

Just want to get this dang thing installed against Symfony 2.2

Contributor
breerly commented Apr 4, 2013

I wasn't able to install the JMSSerializerBundle by itself with Symfony 2.2 either.

schmittjoh/JMSSerializerBundle#285

:(

Contributor
breerly commented Apr 4, 2013

I was able to get it working by removing the rest-bundle and installing it this way.

composer require jms/serializer-bundle #dev-master
composer require friendsofsymfony/rest-bundle #dev-master

Is there not a tagged version of these bundles that works with Symfony 2.2 or should I rely on dev-master for now?

Owner
lsmith77 commented Apr 4, 2013

you need to allow dev versions for now

@lsmith77 lsmith77 closed this Apr 4, 2013

This is still an outstanding issue, the installation documentation is incomplete.

Owner

no its not .. but if you have suggestions to improve feel free to send them .. I will not invest any time in this myself. so it goes

@lsmith77 lsmith77 locked and limited conversation to collaborators Jun 22, 2014
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.