Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Installation error on Ubuntu 18.04 #1313

Closed
royfrancis opened this Issue Feb 16, 2019 · 2 comments

Comments

Projects
None yet
2 participants
@royfrancis
Copy link

royfrancis commented Feb 16, 2019

I get the following error when installing.

$./setup.sh

Gathering system information ...done.
NOTE: Legacy scripts wig-to-json.pl and bam-to-json.pl have been removed from setup. Their functionality has been superseded by add-bam-track.pl and add-bw-track.pl. If you require the old versions, please use JBrowse 1.12.3 or earlier.
Installing node.js dependencies and building with webpack ...done.
Installing Perl prerequisites ... failed.  See setup.log file for error messages. As a first troubleshooting step, make sure development libraries and header files for GD, Zlib, and libpng are installed and try again.

Formatting Volvox example data ... failed.  See setup.log file for error messages.

Formatting Yeast example data ... failed.  See setup.log file for error messages.

Tried to install additional packages as suggested here. Now it's another error.

sudo apt-get install build-essential libpng-dev zlib1g-dev libgd2-xpm-dev

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libgd2-xpm-dev

Here, it is suggested that libgd2-xpm-dev is deprecated and libgd-dev may be used instead. But, installing that doesn't fix the issue.

jbrowse-1.16.2-release
Ubuntu 18.04
I have added this plugin in the plugins directory. Not sure if that matters.

@cmdcolin

This comment has been minimized.

Copy link
Contributor

cmdcolin commented Feb 16, 2019

See #1310 bioperl made a big change to their system. I would recommend manually installing bioperl like this

rm -rf extlib
bin/cpanm -v --notest -l extlib/ Bio::Perl@1.7.2
./setup.sh

That will get the last working bioperl version

We're working to release a new jbrowse with proper fixes

@royfrancis

This comment has been minimized.

Copy link
Author

royfrancis commented Feb 17, 2019

That worked! Thanks.

@royfrancis royfrancis closed this Feb 17, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.