Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

rake/gempackagetask is deprecated. Use rubygems/package_task instead

  • Loading branch information...
commit ead1e1d42c597565553f5c2d5ac58f1ffd1d9672 1 parent 030da4a
@croaky croaky authored
Showing with 2 additions and 2 deletions.
  1. +2 −2 Rakefile
View
4 Rakefile
@@ -2,7 +2,7 @@ require 'rubygems'
require 'bundler/setup'
require 'rake'
require 'rake/rdoctask'
-require 'rake/gempackagetask'
+require 'rubygems/package_task'
require 'rspec/core/rake_task'
require 'cucumber/rake/task'
require 'appraisal'
@@ -33,7 +33,7 @@ RSpec::Core::RakeTask.new(:coverage) do |t|
end
eval("$specification = begin; #{IO.read('shoulda-matchers.gemspec')}; end")
-Rake::GemPackageTask.new $specification do |pkg|
+Gem::PackageTask.new $specification do |pkg|
pkg.need_tar = true
pkg.need_zip = true
end
Please sign in to comment.
Something went wrong with that request. Please try again.