XCode plugin that implements CocoaPods GUI.
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
CocoaPodUI.xcodeproj Add YAML as an explicit dependency of CocoaPodUI Jun 12, 2016
CocoaPodUI Update CocoaPodUI-Info.plist Dec 10, 2015
YAML.framework-master Xcode 6 bug fixes Oct 29, 2014
.gitignore
README.md Update README.md Sep 24, 2016
readme.png

README.md

The project support is stopped due to incompatibility of Xcode 8+ with "classic" plugins.

CocoaPodUI

Xcode plugin that implements CocoaPods GUI.

Installation Guide

Open and build CocoaPodUI project, it will be installed automatically.

Uninstall

Just remove CocoaPodUI.xcplugin from ~/Library/Application Support/Developer/Shared/Xcode/Plug-ins

Version History

  • v.1.2.4
    • (no new features, compatibility fixes) Xcode 6.3.2 and 6.4-beta-3 (6E23).
  • v.1.2.3
    • (no new features, compatibility fixes) Xcode 6.3.1 and 6.4-beta-2 support.
  • v.1.2.2
    • (no new features, compatibility fixes) Xcode 6.2 and 6.3-beta-3 support.
  • v.1.2.1
    • Add Xcode 6-beta support.
  • v.1.2
    • New podspec format support.
    • Checking for outdated Pods and it’s updating.
    • Badge on Xcode Dock icon with outdated Pods count
  • v.1.1
    • Added multi-target support.
    • Adding pods to the «Installed»-table by drag’n’drop.
    • Extended editing capabilities of pods.
  • v.1.0.4 hotfix 2
    • Fixed crash when Cocoapods gem file path is not defined and equals nil.
    • Fixed forming of incorrect text for Podfile.
  • v.1.0.4 hotfix 1
    • «must provide a launch path» crash fix.
  • v.1.0.4
    • Avoid complete overwriting an existing Podfile.
  • v.1.0.3
    • Added console output for during pods install.
  • v.1.0.2 hotfix 2
    • Small bug-fix.
  • v.1.0.2 hotfix 1
    • Cocoapod gem search optimization.
  • v.1.0.2
    • Added mechanism that allows user manually define location of Cocoapods gem file.
  • v.1.0.1
    • Critical bug fixes.
      • Fixed crash when Cocoapod gem placed in non-default folder.
      • Fixed crash when Podfile contains additional pre- or post-install scenarios.
    • Global improvements.
  • v.1.0
    • Basic capabilities: «Podfile» creation and pods installation. Cleaning up project from pods.

Special thanks to kodlian (JMModalOverlay)

Adding support for new builds of XCode

Add the build UUIDs for the versions of Xcode you wish to support to DVTPlugInCompatibilityUUIDs in CocoaPodUI-Info.plist. This UUID can be found by running command in Terminal:

defaults read /Applications/Xcode.app/Contents/Info DVTPlugInCompatibilityUUID

See template project at https://github.com/kattrali/Xcode-Plugin-Template