Permalink
Browse files

Only use PPA for older Ubuntu releases (#961)

  • Loading branch information...
zachriggle committed Apr 28, 2017
1 parent aa3acc1 commit 4772a22fed37899f6bca14b7b92646fe16b53dce
Showing with 8 additions and 3 deletions.
  1. +8 −3 travis/install.sh
View
@@ -65,9 +65,14 @@ setup_travis()
setup_linux()
{
sudo apt-get install -y software-properties-common openssh-server libncurses5-dev libncursesw5-dev openjdk-8-jre-headless
- sudo apt-add-repository --yes ppa:pwntools/binutils
- sudo apt-get update
- sudo apt-get install binutils-arm-linux-gnu binutils-mips-linux-gnu binutils-powerpc-linux-gnu
+ RELEASE="$(lsb-release -sr)"
+ if [[ "$RELEASE" < "16.04" ]]; then
+ sudo apt-add-repository --yes ppa:pwntools/binutils
+ sudo apt-get update
+ sudo apt-get install -y binutils-arm-linux-gnu binutils-mips-linux-gnu binutils-powerpc-linux-gnu
+ else
+ sudo apt-get install -y binutils-arm-linux-gnueabihf binutils-mips-linux-gnu binutils-powerpc-linux-gnu
+ fi
}
setup_android_emulator()

0 comments on commit 4772a22

Please sign in to comment.