Skip to content
Permalink
Browse files

dev3 update README.md installation part (#1338)

* dev3 update README.md installation part

* Update require python version in README.md

Co-Authored-By: Arusekk <arek_koz@o2.pl>
  • Loading branch information...
WildfootW and Arusekk committed Aug 27, 2019
1 parent 460c42b commit 47e967238cd68cca8ecabd8b0dc8fbd681fe93ff
Showing with 4 additions and 4 deletions.
  1. +4 −4 README.md
@@ -32,15 +32,15 @@ To get you started, we've provided some example solutions for past CTF challenge

# Installation

Pwntools is best supported on 64-bit Ubuntu LTE releases (12.04, 14.04, and 16.04). Most functionality should work on any Posix-like distribution (Debian, Arch, FreeBSD, OSX, etc.). Python 2.7 is required.
Pwntools is best supported on 64-bit Ubuntu LTE releases (12.04, 14.04, 16.04 and 18.04). Most functionality should work on any Posix-like distribution (Debian, Arch, FreeBSD, OSX, etc.). Python >= 2.7 is required (Python 3 suggested as best).

Most of the functionality of pwntools is self-contained and Python-only. You should be able to get running quickly with

```sh
apt-get update
apt-get install python2.7 python-pip python-dev git libssl-dev libffi-dev build-essential
pip install --upgrade pip
pip install --upgrade pwntools
apt-get install python3 python3-pip python3-dev git libssl-dev libffi-dev build-essential
python3 -m pip install --upgrade pip
python3 -m pip install --upgrade git+https://github.com/Gallopsled/pwntools.git@dev3
```

However, some of the features (assembling/disassembling foreign architectures) require non-Python dependencies. For more information, see the [complete installation instructions here](https://docs.pwntools.com/en/stable/install.html).

0 comments on commit 47e9672

Please sign in to comment.
You can’t perform that action at this time.