Permalink
Browse files

Add upper bounds to package dependencies, because Hackage is picky.

  • Loading branch information...
1 parent 5062b19 commit 7fbf3d9dd7246525dec3c0b60515a43372cc30f0 @acw acw committed Mar 29, 2012
Showing with 2 additions and 1 deletion.
  1. +2 −1 BoundedChan.cabal
View
@@ -15,7 +15,8 @@ description: This library introduces BoundedChan. BoundedChans differ from
certain number of elements.
library
- build-depends: base >= 3, array
+ build-depends: base >= 3 && < 5,
+ array >= 0.2 && < 0.8
exposed-modules: Control.Concurrent.BoundedChan
ghc-options: -O2 -Wall -funbox-strict-fields
if impl(ghc >= 6.8)

0 comments on commit 7fbf3d9

Please sign in to comment.