New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

LSGM Teamspeak Update Option overwrites Teamspeak Beta Installs #1931

Closed
gOOvER opened this Issue Jul 5, 2018 · 3 comments

Comments

@gOOvER

gOOvER commented Jul 5, 2018

I updated manually Teamspeak to the 3.3.0 beta1. If I have autoupdate enabled, 3.3.0 will be overwritten be 3.2.0.

Maybe you can add an option to use Beta Build s too order ignore if Version is greater than installed.

"ts3@web01:$ ./ts3server sp
[ OK ] Stopping ts3server: TeamSpeak 3 Server
ts3@web01:
$ ./ts3server st
[ OK ] Update ts3server: Checking for update: teamspeak.com

Update available:
Current build: 3.3.0 amd64
Available build: 3.2.0 amd64

Applying update...
extracting teamspeak3-server_linux_amd64-3.2.0.tar.bz2...OK
copying to /home/ts3/serverfiles...OK
"

See also:
https://forum.teamspeak.com/threads/136231-PreRelease-TeamSpeak-3-Server-3-3-0-Beta

@triage-new-issues triage-new-issues bot added the triage label Jul 5, 2018

@gOOvER gOOvER changed the title from Teamspeak Updates overwrites Beta INstalls to LSGM Teamspeak Update Option overwrites Teamspeak Beta Installs Jul 5, 2018

@UltimateByte

This comment has been minimized.

Collaborator

UltimateByte commented Jul 5, 2018

Managing stable teamspeak versions is already a pain because they don't really have a proper structure to check versions... I think we figured a good way though.
I don't see ourselves working on adding beta repos which would probably change structure quite often and be even more of a pain to maintain. If you want to install the beta version, I would suggest downloading such version to your serverfiles directory manually and update it manually as well.

@gOOvER

This comment has been minimized.

gOOvER commented Jul 6, 2018

Maybe only an option to ignore update when Version is higher than the installed one. I think this should be enough. And you will not miss an regular update :)

@dgibbs64

This comment has been minimized.

Member

dgibbs64 commented Jul 21, 2018

Good idea with the ignoring if the available version is higher. That way you can manually install a beta version and not overwrite it until a newer stable is released.

@dgibbs64 dgibbs64 added this to the 180720 milestone Jul 21, 2018

@dgibbs64 dgibbs64 modified the milestones: 180908, Next Release Sep 8, 2018

dgibbs64 added a commit that referenced this issue Oct 27, 2018

Merge pull request #2060 from GameServerManagers/feature/ts3-1931
Teamspeak updater will only update if cur version is less than avail #1931

@dgibbs64 dgibbs64 closed this Oct 27, 2018

@wafflebot wafflebot bot removed the Status: dev queue label Oct 27, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment