Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[ts3server] update_ts3.sh fails when teamspeak was started with 'logappend=1' #2584

Closed
tam1m opened this issue Nov 12, 2019 · 1 comment

Comments

@tam1m
Copy link
Contributor

@tam1m tam1m commented Nov 12, 2019

User Story

The update fails because version detection is broken.

Basic info

  • Distro: [Ubuntu 19.10]
  • Game: [ts3server]
  • Command: [update]

Further Information

The update fails because version detection is broken. If there are more than one version string in a log file, localbuild in update_ts3.sh becomes something like this

3.9.1
3.9.1
3.9.1
3.9.1
3.9.1
3.9.1
3.9.1
3.9.1
3.9.1
3.9.1
3.9.1
3.9.1
3.9.1
3.9.1

To Reproduce

Steps to reproduce the behaviour:
start teamspeak with logappent=1
./ts3server update

Expected behaviour

Detect current installed version correctly

@issue-label-bot issue-label-bot bot added the type: bug label Nov 12, 2019
@issue-label-bot

This comment has been minimized.

Copy link

@issue-label-bot issue-label-bot bot commented Nov 12, 2019

Issue-Label Bot is automatically applying the label type: bug to this issue, with a confidence of 0.99. Please mark this comment with 👍 or 👎 to give our bot feedback!

Links: app homepage, dashboard and code for this bot.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.