Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

adt - unable to install ipa on iPadOS 13 Beta 8 #86

Open
tuarua opened this issue Aug 24, 2019 · 4 comments

Comments

@tuarua
Copy link

commented Aug 24, 2019

Problem Description

iOS 13 is now split into 2 versions, 1 for iPhone, 1 for iPads. The iPads OS will be called "iPadOS" from version 13 onwards. With this name change adt is unable to install apps. Assumption being that adt code is unable to handle the os name change

adt -installApp -platform ios -device 4 -package /Users/Example.ipa 
Error connecting to your device!

adt -devices -platform ios
works OK

Describe your problem in detail. Include the following information:

  • Which AIR SDK did you use?
    33.0.1.220
  • Describe the affected environment:
    AIR iOS on iPad Pro 10.5 with iPadOS 13 Beta 8 installed
  • Can you reproduce it yourself, or did you get reports from other users? If so, how many users are affected (percentage)?
    Will affect developers with iPads who upgrade to iPadOS 13 (unable to install iOS on iPads from 13 onwards) iPadOS is due for release mid September

Steps to Reproduce

  • Install iPadOS 13 Beta on iPad
  • Run adt -devices -platform ios
  • adt -installApp -platform ios -device 4 -package /Users/Example.ipa

Known Workarounds

ipa can be compiled and installed using Xcode and runs OK - but unable to debug from IDE or using adt

@tuarua

This comment has been minimized.

Copy link
Author

commented Aug 25, 2019

Note: This may not be confined to iPadOS but affecting iOS 13 also. I have no way to confirm as I only own iPads and don't have an iPhone to confirm issue is not observed with iOS 13 Beta there.

The error is generated by lib/aot/bin/iOSBin/idb which is called by adt.

eg This results in same error
/Users/AIRSDK/lib/aot/bin/iOSBin/idb -install /Users/project/bin-release/device/Example.ipa 4

Looks like iOSBin/ utils are derived from components of this project.
https://github.com/libimobiledevice

@tuarua

This comment has been minimized.

Copy link
Author

commented Sep 3, 2019

EDIT: confirmed this also affects iOS 13 Beta on iPhone

@nanhuichen

This comment has been minimized.

Copy link

commented Sep 26, 2019

I got the same issue on iPhone7.

@ajwfrost

This comment has been minimized.

Copy link
Collaborator

commented Sep 27, 2019

Hi all

We're aware of this one, and are looking into it, hope to have a fix pushed out before too long. I believe it's possible to download the apps via an old version of iTunes, or via Xcode, as a temporary workaround..

thanks

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.