New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

OpenGL debug crash on Intel HD4000 #1082

Closed
crabmusket opened this Issue Dec 26, 2014 · 3 comments

Comments

Projects
None yet
2 participants
@crabmusket
Contributor

crabmusket commented Dec 26, 2014

Started a project from the development branch using the project generator (with #1081), compiled, switched to OpenGL using settings dialog, restarted the game, loaded the level, and got an access violation crash here.

glGetProgramiv( mProgram, GL_LINK_STATUS, &linkStatus );

console.log

Notice the VRAM is reported as 0, whereas with D3D it's reported correctly as 1746MB.

@crabmusket crabmusket added this to the 3.7 milestone Dec 26, 2014

@LuisAntonRebollo

This comment has been minimized.

Show comment
Hide comment
@LuisAntonRebollo

LuisAntonRebollo Dec 26, 2014

Contributor

@eightyeight, can you test with #1083 Fix/walkaround for OpenGL on Intel?

Contributor

LuisAntonRebollo commented Dec 26, 2014

@eightyeight, can you test with #1083 Fix/walkaround for OpenGL on Intel?

@crabmusket

This comment has been minimized.

Show comment
Hide comment
@crabmusket

crabmusket Dec 26, 2014

Contributor

Will do in the morning :).

Contributor

crabmusket commented Dec 26, 2014

Will do in the morning :).

@crabmusket

This comment has been minimized.

Show comment
Hide comment
@crabmusket

crabmusket Dec 29, 2014

Contributor

Looks like it could be an issue with proprietary drivers I can't update.

Contributor

crabmusket commented Dec 29, 2014

Looks like it could be an issue with proprietary drivers I can't update.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment