New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Big heightmaps fail to load #411

Closed
razvanab opened this Issue Jun 14, 2013 · 11 comments

Comments

Projects
None yet
3 participants
@razvanab

razvanab commented Jun 14, 2013

The engine fail to load heightmaps higher then 1024.

Here is a sample:
output

@crabmusket

This comment has been minimized.

Show comment
Hide comment
@crabmusket

crabmusket Jun 14, 2013

Contributor

What's the current behavior? Crash, or just fails to load?

Contributor

crabmusket commented Jun 14, 2013

What's the current behavior? Crash, or just fails to load?

@razvanab

This comment has been minimized.

Show comment
Hide comment
@razvanab

razvanab Jun 14, 2013

Fails to load.

I forgot to mention that i use the latest development version.

razvanab commented Jun 14, 2013

Fails to load.

I forgot to mention that i use the latest development version.

@thecelloman

This comment has been minimized.

Show comment
Hide comment
@thecelloman

thecelloman Jun 17, 2013

Contributor

The example heightmap appears to import and work just fine for me. Can you provide some specific steps in order for us to reproduce your results?

Contributor

thecelloman commented Jun 17, 2013

The example heightmap appears to import and work just fine for me. Can you provide some specific steps in order for us to reproduce your results?

@razvanab

This comment has been minimized.

Show comment
Hide comment
@razvanab

razvanab Jun 17, 2013

1.import terrain heightmap
2.height scale set to 2048 and meter per pixel 2
3.load up the heightmap

razvanab commented Jun 17, 2013

1.import terrain heightmap
2.height scale set to 2048 and meter per pixel 2
3.load up the heightmap

@razvanab razvanab closed this Jun 17, 2013

@razvanab razvanab reopened this Jun 17, 2013

@thecelloman

This comment has been minimized.

Show comment
Hide comment
@thecelloman

thecelloman Jun 17, 2013

Contributor

Using those settings and the supplied heightmap image works just fine on my end. Have you tried running a Debug build and stepping through the heightmap import code to see where/how/why it's failing for you?

Contributor

thecelloman commented Jun 17, 2013

Using those settings and the supplied heightmap image works just fine on my end. Have you tried running a Debug build and stepping through the heightmap import code to see where/how/why it's failing for you?

@razvanab

This comment has been minimized.

Show comment
Hide comment
@razvanab

razvanab Jun 17, 2013

No but i will try to do another build to see if this will fix the problem

razvanab commented Jun 17, 2013

No but i will try to do another build to see if this will fix the problem

@razvanab

This comment has been minimized.

Show comment
Hide comment
@razvanab

razvanab Jun 18, 2013

It depends on how much vram do you have apparently.
Sorry for the trouble.

razvanab commented Jun 18, 2013

It depends on how much vram do you have apparently.
Sorry for the trouble.

@razvanab razvanab closed this Jun 18, 2013

@crabmusket

This comment has been minimized.

Show comment
Hide comment
@crabmusket

crabmusket Jun 18, 2013

Contributor

Is there any way we could improve the feedback? For example, adding an error message (popup, or print to the console) when this happens?

Contributor

crabmusket commented Jun 18, 2013

Is there any way we could improve the feedback? For example, adding an error message (popup, or print to the console) when this happens?

@razvanab

This comment has been minimized.

Show comment
Hide comment
@razvanab

razvanab Jun 18, 2013

No error message in console but I tried on another pc with 4 Gb Ram and 2 Gb Vram and it's working

razvanab commented Jun 18, 2013

No error message in console but I tried on another pc with 4 Gb Ram and 2 Gb Vram and it's working

@crabmusket

This comment has been minimized.

Show comment
Hide comment
@crabmusket

crabmusket Jun 18, 2013

Contributor

Yep, I'm thinking that for the next person who has this problem, it'd be nice to give them a warning about the cause of the issue. Otherwise people will keep asking this question. If there's a single point in the import process that fails, we could stick a script callback there.

Contributor

crabmusket commented Jun 18, 2013

Yep, I'm thinking that for the next person who has this problem, it'd be nice to give them a warning about the cause of the issue. Otherwise people will keep asking this question. If there's a single point in the import process that fails, we could stick a script callback there.

@razvanab

This comment has been minimized.

Show comment
Hide comment
@razvanab

razvanab Mar 1, 2016

I now have a better video card with 2048 memory and t3d does the same:
it doesn't load heightmaps bigger then 1024.

razvanab commented Mar 1, 2016

I now have a better video card with 2048 memory and t3d does the same:
it doesn't load heightmaps bigger then 1024.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment