New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Apk install - INSTALL_FAILED_OLDER_SDK #77

Closed
vb078 opened this Issue Jan 6, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@vb078

vb078 commented Jan 6, 2018

Hello

I realy love gnirehtet concept ;)
I am on mac, using android 4.4.2
I try to get SDK version from adb :

$ adb shell getprop ro.build.version.sdk
19
$ adb shell getprop ro.build.version.release
4.4.2

The connexion seems to work, I have a key confirmation on my phone.
But, if I understand well, I need to install the apk (with adb installed with 'brew')
and, when I try I have two errors :

  1. INSTALL_FAILED_OLDER_SDK]
  2. different versions of 'client' and 'server' (says adb)
./gnirehtet run
2018-01-06 03:25:14.763 I Gnirehtet: Checking gnirehtet client...
2018-01-06 03:25:19.256 I Gnirehtet: Installing gnirehtet client...
gnirehtet.apk: 1 file pushed. 0.9 MB/s (20616 bytes in 0.022s)
	pkg: /data/local/tmp/gnirehtet.apk
Failure [INSTALL_FAILED_OLDER_SDK]
2018-01-06 03:25:22.561 I Gnirehtet: Starting client...
2018-01-06 03:25:22.574 I Gnirehtet: Starting relay server...
error: closed
2018-01-06 03:25:22.622 E Gnirehtet: Cannot start client
com.genymobile.gnirehtet.relay.CommandExecutionException: Command [adb, reverse, tcp:31416, tcp:31416] returned with value 1
	at com.genymobile.gnirehtet.Main.execSync(Main.java:218)
	at com.genymobile.gnirehtet.Main.execAdb(Main.java:192)
	at com.genymobile.gnirehtet.Main.startClient(Main.java:246)
	at com.genymobile.gnirehtet.Main.access$500(Main.java:32)
	at com.genymobile.gnirehtet.Main$Command$4.lambda$execute$0(Main.java:104)
	at java.lang.Thread.run(Thread.java:745)
2018-01-06 03:25:23.138 I Relay: Relay server started

Can you help ?
I dont know how to change 'minSdkVersion' and 'maxSdkVersion'...
I try 'apktool'... to decompil and change it.

I try fdmobileinventions reversetethering (working great but not so open)

Have a good day

@vb078 vb078 changed the title from Ak install - INSTALL_FAILED_OLDER_SDK to Apk install - INSTALL_FAILED_OLDER_SDK Jan 6, 2018

@rom1v

This comment has been minimized.

Show comment
Hide comment
@rom1v

rom1v Jan 6, 2018

Collaborator

It requires Android 5. See #2

Collaborator

rom1v commented Jan 6, 2018

It requires Android 5. See #2

@vb078

This comment has been minimized.

Show comment
Hide comment
@vb078

vb078 Jan 6, 2018

Ok, thanks, I didnt see it.
Let me know if someone find a rooted solution or an other way ;)

vb078 commented Jan 6, 2018

Ok, thanks, I didnt see it.
Let me know if someone find a rooted solution or an other way ;)

@vb078 vb078 closed this Jan 6, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment