Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Email returns a blank page #1178

Closed
Sortova opened this issue Apr 4, 2015 · 1 comment

Comments

@Sortova
Copy link

commented Apr 4, 2015

When sending an e-mail, the webUI will return a blank page and generate the following log (Luna 0.7.0):

PHP Fatal error: Call to undefined function luna_mail() in /var/www/html/forum/new_inbox.php on line 257, referer: https://luna.example.com/forum/new_inbox.php

The following patch will fix it.

$ diff new_inbox.php.org new_inbox.php

11a12
> require FORUM_ROOT.'include/email.php';
-bash-4.1$ diff -p new_inbox.php.org new_inbox.php
*** new_inbox.php.org   2015-04-04 09:08:17.174438628 -0500
--- new_inbox.php   2015-04-04 09:07:54.642815980 -0500
***************
*** 9,14 ****
--- 9,15 ----
  define('FORUM_ROOT', dirname(__FILE__).'/');
  require FORUM_ROOT.'include/common.php';
  require FORUM_ROOT.'include/inbox_functions.php';
+ require FORUM_ROOT.'include/email.php';
  
  // No guest here !
  if ($luna_user['is_guest'])
@Studio384 Studio384 added the bug label Apr 4, 2015
@Studio384 Studio384 added this to the Luna 1.0 Aero milestone Apr 4, 2015
@Studio384

This comment has been minimized.

Copy link
Member

commented Apr 4, 2015

Thanks, the fix will be included in the RC2 build.

@Studio384 Studio384 referenced this issue Apr 5, 2015
322 of 322 tasks complete
@Studio384 Studio384 closed this Apr 5, 2015
Studio384 pushed a commit that referenced this issue Apr 5, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.