Skip to content
Browse files

fixing gemfile and rakefile

  • Loading branch information...
1 parent 3398d22 commit 31585e595094d4206313d88459fded6598ffb47a @dimus dimus committed Sep 3, 2013
Showing with 38 additions and 29 deletions.
  1. +0 −1 .rvmrc
  2. +14 −1 Gemfile
  3. +8 −15 Gemfile.lock
  4. +16 −1 Rakefile
  5. +0 −11 biodiversity.gemspec
View
1 .rvmrc
@@ -1 +0,0 @@
-rvm use ruby-2.0.0-p247@biodiversity --create
View
15 Gemfile
@@ -1,3 +1,16 @@
source 'https://rubygems.org'
-gemspec
+gem 'treetop', '~> 1.4'
+gem 'parallel', '~> 0.7'
+gem 'unicode_utils', '~> 1.4'
+
+group :development do
+ # gem 'bundler', '~> 1.3'
+ gem 'rake', '~> 10.1'
+ gem 'debugger', '~> 1.6'
+end
+
+group :test do
+ gem 'rspec', '~> 2.14'
+ gem 'rr', '~> 1.1'
+end
View
23 Gemfile.lock
@@ -1,16 +1,3 @@
-PATH
- remote: .
- specs:
- biodiversity (3.1.3)
- bundler (~> 1.3)
- debugger (~> 1.6)
- parallel (~> 0.7)
- rake (~> 10.1)
- rr (~> 1.1)
- rspec (~> 2.14)
- treetop (~> 1.4)
- unicode_utils (~> 1.4)
-
GEM
remote: https://rubygems.org/
specs:
@@ -22,7 +9,7 @@ GEM
debugger-linecache (1.2.0)
debugger-ruby_core_source (1.2.3)
diff-lcs (1.2.4)
- parallel (0.7.1)
+ parallel (0.8.0)
polyglot (0.3.3)
rake (10.1.0)
rr (1.1.2)
@@ -43,4 +30,10 @@ PLATFORMS
ruby
DEPENDENCIES
- biodiversity!
+ debugger (~> 1.6)
+ parallel (~> 0.7)
+ rake (~> 10.1)
+ rr (~> 1.1)
+ rspec (~> 2.14)
+ treetop (~> 1.4)
+ unicode_utils (~> 1.4)
View
17 Rakefile
@@ -1,6 +1,21 @@
-require 'bundler/gem_tasks'
+require 'bundler'
+Bundler::GemHelper.install_tasks
+
+begin
+ Bundler.setup(:default, :development)
+rescue Bundler::BundlerError => e
+ $stderr.puts e.message
+ $stderr.puts 'Run `bundle install` to install missing gems'
+ exit e.status_code
+end
+
require 'rspec/core'
require 'rspec/core/rake_task'
+require 'rake/dsl_definition'
+require 'rake'
+require 'rspec'
+require 'rspec/core/rake_task'
+
task :default => :spec
View
11 biodiversity.gemspec
@@ -2,7 +2,6 @@ $:.push File.expand_path("../lib", __FILE__)
require 'biodiversity/version'
-# Describe your gem and declare its dependencies:
Gem::Specification.new do |s|
s.name = 'biodiversity'
s.version = Biodiversity::VERSION
@@ -15,14 +14,4 @@ Gem::Specification.new do |s|
s.files = `git ls-files`.split("\n")
s.executables = ['nnparse', 'parserver']
s.require_paths = ['lib']
-
- s.add_dependency 'treetop', '~> 1.4'
- s.add_dependency 'parallel', '~> 0.7'
- s.add_dependency 'unicode_utils', '~> 1.4'
-
- s.add_dependency 'bundler', '~> 1.3'
- s.add_dependency 'rake', '~> 10.1'
- s.add_dependency 'debugger','~> 1.6'
- s.add_dependency 'rspec', '~> 2.14'
- s.add_dependency 'rr', '~> 1.1'
end

0 comments on commit 31585e5

Please sign in to comment.
Something went wrong with that request. Please try again.