Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Backwards Compatibility #9

Closed
bradt opened this issue Sep 24, 2015 · 5 comments

Comments

@bradt
Copy link
Contributor

commented Sep 24, 2015

How much should we worry about backwards compatibility?

When it comes to plugins, I don't think we should worry at all. All GlotPress plugins will need to be converted to WordPress plugins anyways as per #7.

Themes might be a different story. I'm sure lots of people have heavily customized their GlotPress themes, so it would be nice to allow people to switch to the GlotPress plugin from a standalone install using their existing GlotPress theme. Would be great to hear from people who have a custom GlotPress theme...

@bradt bradt added this to the Convert to Plugin milestone Sep 24, 2015

@toolstack

This comment has been minimized.

Copy link
Contributor

commented Sep 25, 2015

Backwards compatibility shouldn't be a major concern in my opinion. GP has never had an official 1.0 release so everything is up for grabs.

@bradt

This comment has been minimized.

Copy link
Contributor Author

commented Sep 25, 2015

The version number shouldn't be a factor here. There's people using GP in production environments and depending on it. If we can make it easier for them to adopt the plugin with little effort, we should do it.

@toolstack

This comment has been minimized.

Copy link
Contributor

commented Sep 25, 2015

As long as it doesn't burden us with lots of hacks to support the old I agree, but anyone converting to the plugin version is likely going to be doing so very carefully to start with. If there is something that has to be converted or changed from the old to the new it should be a one of script with instructions for the admin, not something that runs all the time as part of the plugin.

@bradt

This comment has been minimized.

Copy link
Contributor Author

commented Oct 1, 2015

@ocean90

This comment has been minimized.

Copy link
Member

commented Oct 19, 2015

I've started a wiki page which mentions some of the breaking changes: https://github.com/deliciousbrains/GlotPress/wiki/1.1-Breaking-Changes

@bradt bradt closed this Oct 25, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.